Bug 1480101 - Cannot join cluster Default which is compatible with VDSM versions [4.13, 4.14, 4.9, 4.11, 4.12, 4.10]
Cannot join cluster Default which is compatible with VDSM versions [4.13, 4.1...
Status: NEW
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.16.20
x86_64 Linux
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Dan Kenigsberg
Raz Tamir
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 03:25 EDT by loloevian
Modified: 2017-08-14 21:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description loloevian 2017-08-10 03:25:51 EDT
Description of problem:

Hello everybody , 

Node : CentOS6.8 (I don't have the possibility to update the OS version, that a requirement to use a software from our partner)


I installed VDSM on the node. 

command line : yum -y install http://resources.ovirt.org/pub/yum-repo/ovirt-release34.rpm


On the /etc/libvirt/libvirtd.conf
I modified 2 parameters :
listen_tcp=0
auth_tcp="sasl"
And on the qemu.conf:
spice_tls=1

The service is started.

When I move on the GUI https://<IP>/ovirt-engine/
I created my new host and define the network.

When I tried to Activate , I have this message :

Host S10006 is installed with VDSM version (Non interactive user) and cannot join cluster Default which is compatible with VDSM versions [4.13, 4.14, 4.9, 4.11, 4.12, 4.10].


VDSM version 
rpm -qa |grep vdsm
vdsm-xmlrpc-4.16.20-1.git3a90f62.el6.noarch
vdsm-python-zombiereaper-4.16.20-1.git3a90f62.el6.noarch
vdsm-yajsonrpc-4.16.20-1.git3a90f62.el6.noarch
vdsm-jsonrpc-4.16.20-1.git3a90f62.el6.noarch
vdsm-cli-4.16.20-1.git3a90f62.el6.noarch
vdsm-4.16.20-1.git3a90f62.el6.x86_64
vdsm-python-4.16.20-1.git3a90f62.el6.noarch


Question : 
Is it possible to downgrade to the version on the list [4.13, 4.14, 4.9, 4.11, 4.12, 4.10] ?

Have a nice day
Laurent
Comment 1 Michal Skrivanek 2017-08-11 01:04:58 EDT
why do you install 3.4 and not 3.5, that also supports RHEL 6
why do you manually change libvirtd.conf? That's done on host deploy. 
what ovirt-engine version are you trying to install it into? 3.4/3.5 is only supported in manager 3.6 at most. 4.0+ only supports 3.6+ hosts
Comment 2 loloevian 2017-08-14 21:50:39 EDT
(In reply to Michal Skrivanek from comment #1)
> why do you install 3.4 and not 3.5, that also supports RHEL 6
Documentation provided by my manager 
> why do you manually change libvirtd.conf? That's done on host deploy. 
If I didn't modify the conf file, the service didn't start
> what ovirt-engine version are you trying to install it into? 3.4/3.5 is only
> supported in manager 3.6 at most. 4.0+ only supports 3.6+ hosts
version installed  : 3.4.4-1.el6 


for a CentOS 6.8 open virtualization manager , what's the correct version is compatible with my host as regards of the error message 
 

Host S10006 is installed with VDSM version (Non interactive user) and cannot join cluster Default which is compatible with VDSM versions [4.13, 4.14, 4.9, 4.11, 4.12, 4.10].


Have a nice day
Laurent

Note You need to log in before you can comment on or make changes to this bug.