Bug 1480206 - WPA 2 Enterprise doesn't work with SELinux enabled even though certificate file is labelled with home_cert_t
WPA 2 Enterprise doesn't work with SELinux enabled even though certificate fi...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
26
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 08:12 EDT by Jonas Thiem
Modified: 2017-08-14 15:08 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-14 15:08:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonas Thiem 2017-08-10 08:12:18 EDT
Description of problem:
WPA 2 Enterprise doesn't work with SELinux enabled even though certificate file is labelled with home_cert_t. The only method I managed to connect is by using sudo setenforce 0.

Since there is also no proper error message (I just get repeated Wifi password prompts) I really have no idea why, and I don't know what to do about it. Since this worked on previous Fedora versions with proper certificate file labelling, it seems like a bug / regression.


Version-Release number of selected component (if applicable):
3.13.1-260.3.fc26

How reproducible:
100%

Steps to Reproduce:
1. Configure WPA 2 Enterprise linux wifi with certificate file labelled as home_cert_t
2. Try to connect

Actual results:
repeated password prompts and no useful error, unless sudo setenforce 0 was previously used

Expected results:
works

Additional info:
Comment 1 Daniel Walsh 2017-08-14 09:40:49 EDT
What AVC are you getting?
Comment 2 Jonas Thiem 2017-08-14 15:08:40 EDT
I didn't get any sort of visible notification at all, it just plain didn't work.

I realized later my home didn't have proper labels because I copied it from a location without SELinux in the filesystem. Restoring all home labels fixed it!

Note You need to log in before you can comment on or make changes to this bug.