Bug 1480211 - Error: Failed to apply catalog: Insufficient credentials to authenticate (Understack on AWS) [NEEDINFO]
Error: Failed to apply catalog: Insufficient credentials to authenticate (Und...
Status: NEW
Product: RDO
Classification: Community
Component: instack-undercloud (Show other bugs)
Ocata
x86_64 Linux
unspecified Severity medium
: ---
: trunk
Assigned To: James Slagle
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 08:17 EDT by Ivan Krempasky
Modified: 2017-08-14 07:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
chris.brown: needinfo? (ivan.krempasky)


Attachments (Terms of Use)
controller.pp log (1.41 MB, application/octet-stream)
2017-08-10 08:17 EDT, Ivan Krempasky
no flags Details

  None (edit)
Description Ivan Krempasky 2017-08-10 08:17:39 EDT
Created attachment 1311726 [details]
controller.pp log

Description of problem:

  Error at Phase :$ sudo packstack --allinone

...
...
...
Preparing Puppet manifests                        [ DONE ]
Copying Puppet modules and manifests              [ DONE ]
Applying 172.31.28.159_controller.pp
172.31.28.159_controller.pp:                      [ ERROR ]
Applying Puppet manifests                         [ ERROR ]
ERROR : Error appeared during Puppet run: 172.31.28.159_controller.pp
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-keystone' returned 1: Error: Package: py                                                               thon-repoze-who-2.1-1.el7.noarch (openstack-ocata)


  
[root@ip-172-31-24-151 puppet]# tail /var/tmp/packstack/20170810-072246-OAjEIe/manifests/172.31.24.151_controller.pp.log   Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Dependency Package[keystone] has failures: true
Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Dependency Package[neutron] has failures: true
Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Dependency Package[neutron-plugin-ml2] has failures: true
Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Dependency Package[gnocchi-indexer-sqlalchemy] has failures: true
Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Dependency Package[gnocchi] has failures: true
Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Dependency Package[gnocchi-api] has failures: true
Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Dependency Package[gnocchi-metricd] has failures: true
Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Dependency Package[gnocchi-statsd] has failures: true
Warning: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Skipping because of failed dependencies
Error: Failed to apply catalog: Insufficient credentials to authenticate






Version-Release number of selected component (if applicable):

[root@ip-172-31-24-151 etc]# cat os-release
NAME="Red Hat Enterprise Linux Server"
VERSION="7.4 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Server"
VARIANT_ID="server"
VERSION_ID="7.4"
PRETTY_NAME="Red Hat Enterprise Linux Server 7.4 (Maipo)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.4:GA:server"



How reproducible:


1.Provision an 8GB RAM RHEL server on AWS

2.Install missing python-docutils package 
   yum install python-docutils-0.12-0.7.20140510svn7747.fc25.noarch.rpm
   download link: https://www.rpmfind.net/linux/rpm2html/search.php?query=python-docutils 

3.Execute
   sudo yum install -y https://www.rdoproject.org/repos/rdo-release.rpm
   sudo yum update -y
   sudo yum install -y openstack-packstack
   sudo packstack --allinone
Comment 1 Christopher Brown 2017-08-14 07:25:45 EDT
Hi Ivan,

Whereabouts are you installing the python-docutils - that looks like an fc25 package on RHEL 7.4?

Can you clarify please?

Note You need to log in before you can comment on or make changes to this bug.