Bug 148025 - system-config-date needs to be able to set Etc/GMT as timezone
system-config-date needs to be able to set Etc/GMT as timezone
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-14 17:05 EST by Tom Wood
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-16 11:06:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Wood 2005-02-14 17:05:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
There needs to be an easy way to set GMT as the preferred timezone.  Right now, this requires replacing /etc/localtime and editing /etc/sysconfig/clock by hand.

If you make these changes manually, and then decide to use system-config-date for something else, your manual changes are overridden by whatever timezone is set in the tool, even if you don't change anything in the Time Zone tab.

Version-Release number of selected component (if applicable):
system-config-date-1.7.13-0.fc3.1

How reproducible:
Always

Steps to Reproduce:
1. Run system-config-date
2. See that timezones are limited to actual geographic locations.
3. Watch previous manual edits vanish when exiting the tool.
  

Actual Results:  Time zone reverted to whatever was selected in the Time Zone tab.

Expected Results:  This is probably by design.  Would be nice to have the tool use Etc/* as selections as well.

Additional info:

A lot of scientific shops, especially with a global exposure, would appreciate this enhancement.
Comment 1 Dan Vietor 2005-04-18 16:31:30 EDT
(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111
Firefox/1.0
> 
> Description of problem:
> There needs to be an easy way to set GMT as the preferred timezone.  Right
now, this requires replacing /etc/localtime and editing /etc/sysconfig/clock by
hand.
> 
> If you make these changes manually, and then decide to use system-config-date
for something else, your manual changes are overridden by whatever timezone is
set in the tool, even if you don't change anything in the Time Zone tab.
> 
> Version-Release number of selected component (if applicable):
> system-config-date-1.7.13-0.fc3.1
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1. Run system-config-date
> 2. See that timezones are limited to actual geographic locations.
> 3. Watch previous manual edits vanish when exiting the tool.
>   
> 
> Actual Results:  Time zone reverted to whatever was selected in the Time Zone tab.
> 
> Expected Results:  This is probably by design.  Would be nice to have the tool
use Etc/* as selections as well.
> 
> Additional info:
> 
> A lot of scientific shops, especially with a global exposure, would appreciate
this enhancement.

What I do is to add:

UT      +0000+00000     UTC

to the end of the /usr/share/zoneinfo/zone.tab file.  This will create a
selection point at 0,0 (lat lon over Atlantic) so you can select UTC for the
time zone.
Comment 2 Dan Vietor 2005-04-18 17:31:56 EDT
BTW, make sure there are tabs, not spaces between each column.
Comment 3 Florian Brand 2005-11-16 06:52:34 EST
> Actual Results:  Time zone reverted to whatever was selected in the Time Zone tab.

this makes it an error, not an enhancement. Pls. change the severity acordingly.
BTW: this issue also affects RHEL4
Comment 4 Tom Wood 2005-11-17 11:43:01 EST
Changes severity to normal from enhancement per comment #3 above.  Thank you,
Florian.
Comment 5 Nils Philippsen 2006-01-16 11:06:06 EST
system-config-date-1.7.99.14 allows UTC, GMT and GMT relative timezones.

Note You need to log in before you can comment on or make changes to this bug.