Bug 1480359 - "Upload Package" section not showing in the WebUI for non-admin user
"Upload Package" section not showing in the WebUI for non-admin user
Status: VERIFIED
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
6.2.7
Unspecified Unspecified
high Severity high (vote)
: GA
: --
Assigned To: satellite6-bugs
Radovan Drazny
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 15:50 EDT by pm-sat@redhat.com
Modified: 2017-09-19 09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1429624
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upload button present (92.50 KB, image/png)
2017-09-19 09:20 EDT, Radovan Drazny
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 17481 None None None 2017-08-10 15:50 EDT

  None (edit)
Comment 2 Radovan Drazny 2017-09-19 09:18:14 EDT
Tested using the reproducer from the initial report. Created 
 * Custom_product with the Custom_repo
 * Custom_bug_role with necessary filters
 * Test_bug_user, assigned the Custom_bug_role to it

CLI:
$ hammer -u Test_bug_user -p password shell

hammer> repository upload-content --product Custom_Product --name "Custom Repo" --organization "Test org 1" --path rpms/spacewalk-java-2.5.14-97.el6sat.noarch.rpm
Successfully uploaded file 'spacewalk-java-2.5.14-97.el6sat.noarch.rpm'.

WebUI: 
The Upload button is present on the Custom_repo page (see the attached image "upload_button_present.png"). The upload of a package was successfully performed using the WebUI.
Comment 3 Radovan Drazny 2017-09-19 09:20 EDT
Created attachment 1327942 [details]
Upload button present

Note You need to log in before you can comment on or make changes to this bug.