This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 148037 - Display resolution change makes the screen scroll, does not resize
Display resolution change makes the screen scroll, does not resize
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-14 21:12 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-16 17:07:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-02-14 21:12:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
Hi, changing the resolution from 1024x768 to 1600x1200 with
gnome-display-properties
results in my screen becoming scrollable, rather 
than resizing it to the new resolution. 

Also, every time my computer starts up gdm tries the largest resolution there
is (1600x1200), completely ignoring the 1024x768 I have in xorg.conf as the 
first resolution to try. That's another bug, but the point is, it becomes
scrollable at 1600x1200 on startup too. That's why I'm filing a bug on xorg,
and not on gnome-display-properties.

I configured this myself, but I think it's right.

Section "Monitor"
        Identifier   "Sun Monitor"
        VendorName   "Sun Microsystems"
        ModelName    "Sun 20-inch N2 - GDM20E20 (Sony)"
        HorizSync    30.0 - 82.0
        VertRefresh  48.0 - 160.0
        Option      "dpms"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Nvidia GLX"
        Monitor    "Sun Monitor"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1024x768" "1600x1200" "1280x960" "1152x864" "800x600" "640x480"
        EndSubSection
EndSection

The nvidia driver has nothing to do with this - it does the same thing
with nv. Furthermore I see no errors of interest in the log when I
change resolution.

If you'd like startup info from the X log let me know what you need.

This has been the behavior of this monitor for a very long time - 
(ever since I added 1600x1200 as an available resolution, actually).
I just never filed the bug until now. I have another 15 inch monitor 
that does not create any such problems. 

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1

How reproducible:
Always

Steps to Reproduce:
See summary  

Additional info:
Comment 1 Ivan Gyurdiev 2005-02-14 21:16:20 EST
In case this is related...

I play UT2004 demo in 1600x1200 (which is why I need to switch the 
resolution in the first place). However it normally refuses to switch
from my desktop resolution of 1024x768, and that's when I try to change
it with gnome-display-properties. 

It produces the following error message on startup, before it dies.

WARNING: ALC_EXT_capture is subject to change!
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  135 (XFree86-VidModeExtension)
  Minor opcode of failed request:  10 (XF86VidModeSwitchToMode)
  Value in failed request:  0xb6
  Serial number of failed request:  142
  Current serial number in output stream:  143




Comment 2 Sammy 2005-02-15 11:10:41 EST
yes, I seem to have the same problem with radeon 7000. One big effect 
is on "nedit" editor I run under KDE. I think the problem is with the visual 
depth. If I set it to 16 bit nedit comes up fast as it used to, but if I set it 
to 24 it really slows down. By the way in both nedit is showing 32 bit truecolor. 
Comment 3 Mike A. Harris 2005-02-16 17:07:09 EST
> Also, every time my computer starts up gdm tries the largest resolution there
> is (1600x1200), completely ignoring the 1024x768 I have in xorg.conf as the 
> first resolution to try. That's another bug, but the point is, it becomes
> scrollable at 1600x1200 on startup too. That's why I'm filing a bug on xorg,
> and not on gnome-display-properties.

This is expected documented behaviour of the X server.  The size of the root
window by default, is whatever the largest listed mode is.  It does not matter
if you reorder a different mode in front of the largest.  The screen size
(root window) will always be the size of the largest resolution listed.  If
you list a smaller mode in front of that, then you will end up with a virtual
desktop of 1600x1200 with a physical resolution of 1024x768.  The X server
has worked like this forever.  It's actually a feature.

This is entirely a configuration technical support issue.  Please use the
X.Org mailing lists on freedesktop.org to find out how to reconfigure
your server in a way that is closer to what you prefer.

Comment 4 Mike A. Harris 2005-02-16 17:07:47 EST
Setting status to "NOTABUG"
Comment 5 Ivan Gyurdiev 2005-02-16 18:49:31 EST
What's the point of having a default mode, and then a default
root window size that's not equal to that mode? Seems like a bug to me.

Is there any way at all I can get gdm in 1024x768
while still having 1600 available for later? It's not
cool at all that gdm won't allow the user to choose this option.

Also, the unreal thing I posted still occurs. Should I file another bug?

Also, I can't switch modes with CTRL-ALT-+/-. File bug?

Note You need to log in before you can comment on or make changes to this bug.