Bug 1480478 - Two vhost process works while there was only one netperf session bonding to a single vcpu
Two vhost process works while there was only one netperf session bonding to a...
Status: CLOSED DUPLICATE of bug 1480479
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.4-Alt
ppc64le Linux
unspecified Severity high
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-11 04:51 EDT by junma@redhat.com
Modified: 2017-08-11 05:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-11 05:14:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description junma@redhat.com 2017-08-11 04:51:22 EDT
Description of problem:
Two vhost process works while there was only one netperf seesion bonding to a single vcpu (use taskset), but the expected result is only one vhost process working

Version-Release number of selected component (if applicable):
Hardware : P8/P9 ppc64le
Kernel : 4.11.0-16.el7a.ppc64le
Oprating system (ISO): RHEL-ALT-7.4-20170726.0-Server-ppc64le-dvd1.iso
Qemu-kvm version : 2.9.0(qemu-kvm-2.9.0-18.el7a)

How reproducible:

3/5

Steps to Reproduce:
1.boot a guest with 
-device virtio-net-pci,netdev=dev1,mac=9a:e8:e9:ea:eb:ec,id=net1,vectors=10,mq=on \
-netdev tap,id=dev1,vhost=on,script=/etc/ifup_script,downscript=/etc/ifdown_script,queues=4 \
-smp 4
2..In guest, enable the queues (eth0 is the interface name, modify it to you real interface name)
For linux, # ethtool -L eth0 combined 4
3..Run netserver in host and Run 4 netperf sessions in guest
host#netserver
guest#taskset -c 0 netperf -H $HOST_IP -l 60
4.During netperf test, check the vhost process in host.
host # pgrep vhost
host # top -p $all_vhost_pid

Actual results:
after step 5, sometimes there were two vhost processes working

Expected results:

 after step 5, only one cpu works in the cpu interrupts and in host, only one
vhost process works
Additional info:

here is my command line:

/usr/libexec/qemu-kvm -name majun-vm -machine pseries,accel=kvm,usb=off -m 4G -realtime mlock=off -smp 1,sockets=1,cores=1,threads=4 \
-monitor stdio \
-rtc base=localtime,clock=host \
-no-shutdown \
-serial unix:test_install,server,nowait \
-boot strict=on \
-device nec-usb-xhci,id=usb,bus=pci.0,addr=0x2 \
-device pci-ohci,id=usb1,bus=pci.0,addr=0x1 \
-device spapr-vscsi,id=scsi0,reg=0x1000 \
-drive file=/home/test_home/junma/virtdisk/guest-boot.img,if=none,id=drive-scsi0-0-0-0,format=qcow2,cache=none \
-drive file=/home/test_home/junma/iso/RHEL-ALT-7.4-20170726.0-Server-ppc64le-dvd1.iso,if=none,id=drive-scsi0-0-1-0,readonly=on,format=raw,cache=none \
-device scsi-cd,bus=scsi0.0,channel=0,scsi-id=1,lun=0,drive=drive-scsi0-0-1-0,id=scsi0-0-1-0,bootindex=2 \
-device usb-kbd,id=input0 \
-device usb-mouse,id=input1 \
-device usb-tablet,id=input2 \
-vnc 0:16 -device VGA,id=video0,vgamem_mb=16,bus=pci.0,addr=0x4 \
-device virtio-blk-pci,id=blk0,bus=pci.0,addr=0x3,drive=drive-scsi0-0-0-0,bootindex=1 \
-device virtio-net-pci,netdev=dev1,mac=9a:e8:e9:ea:eb:ef,id=net1,vectors=10,mq=on \
-msg timestamp=on \
-netdev tap,id=dev1,vhost=on,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown,queues=4 \
Comment 2 Zhengtong 2017-08-11 05:14:34 EDT
This bug should be a mistaking filed one. refer to bz 1480479

*** This bug has been marked as a duplicate of bug 1480479 ***

Note You need to log in before you can comment on or make changes to this bug.