Bug 1480842 - Anaconda suggests classic partition can span more than one device
Anaconda suggests classic partition can span more than one device
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
26
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-12 04:14 EDT by Alexander van Loon
Modified: 2017-08-21 05:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 05:08:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of manual partitioning with sda2 (114.27 KB, image/png)
2017-08-12 04:14 EDT, Alexander van Loon
no flags Details

  None (edit)
Description Alexander van Loon 2017-08-12 04:14:16 EDT
Created attachment 1312371 [details]
Screenshot of manual partitioning with sda2

I use a PC with an SSD and an HDD. For my installation of Fedora 26 I chose to overwrite the existing installation of Fedora 24 (only OS which was present). I decided to use manual partitioning in combination with LVM and noticed that two logical volumes and three classic partitions were suggested by the installer. These were:
Logical volume: fedora-home where /home would be mounted.
Logical volume: fedora-root where / would be mounted.
Logical volume: fedora-swap which would be used as swap.
Classical partition: sda1 where /boot/efi would be mounted.
Classical partition: sda2 where /boot would be mounted.

To me it made sense to create the fedora-root and fedora-swap logical volumes and both classic partitions on my SSD, without encryption. Then the fedora-home logical volume would be created on my HDD and be encrypted.

As you can notice in the screenshot however, Anaconda suggests that the classical partition sda2 with /boot (as well as sda1) would be installed on both my SSD and HDD. I managed to correct this, but I wonder how this is even possible? It seems that Anaconda is confusing LVM and classical partitioning, because as far as I know it is not possible to have one classical partition span more than one physical storage device, right? Can this be fixed in the installer?
Comment 1 Jiri Konecny 2017-08-21 05:08:26 EDT
Hello Alexander,

This behavior is intentional. You can specify how many partitions you want and then we will try to pick the one which is best for that purpose.

It will be of course installed only on one of the selected partitions.

Note You need to log in before you can comment on or make changes to this bug.