Bug 1480926 - "Task Status of Volume" message in volume status doesn't go away after rebalance completes.
"Task Status of Volume" message in volume status doesn't go away after rebala...
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute (Show other bugs)
3.2
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Nithya Balachandran
Prasad Desala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-12 19:00 EDT by Ben Turner
Modified: 2017-08-13 12:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-13 12:28:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Turner 2017-08-12 19:00:46 EDT
Description of problem:

After I run a rebalance I see the following when running volume status:

Task Status of Volume data
------------------------------------------------------------------------------
Task                 : Rebalance           
ID                   : b910bb93-8391-4094-8bc4-49df04a92da9
Status               : completed     

The rebalance completed successfully but the Task Status remains until I run gluster v rebalance data stop.  Once I run stop the message goes away, but instead of hanging around indefinitely I think the Task Status should go away when the rebalance is successfully completed.  Is needing to run rebalance stop even when the rebalance is successful and complete necessary or is this a bug?  If this is intended behavior what is the reason and what are your thoughts on changing this behavior?


Version-Release number of selected component (if applicable):

glusterfs-3.8.4-18.4.el7rhgs.x86_64

How reproducible:

Anytime I run gluster v status after running rebalance.

Steps to Reproduce:
1.  Run rebal.
2.  Let it complete successfully.
3.  Run gluster v status.

Actual results:

I see the following:

Task Status of Volume data
------------------------------------------------------------------------------
Task                 : Rebalance           
ID                   : b910bb93-8391-4094-8bc4-49df04a92da9
Status               : completed  

This was in the volume status output even weeks after the successful rebalance.

Expected results:

After the rebalance completes successfully the Task Status message no longer shows when running gluster v status.

Additional info:

If needing to run rebalance stop to clear the message is indeed necessary and the behavior cannot be changed, can we note this specifically in the documentation?

Note You need to log in before you can comment on or make changes to this bug.