Bug 14822 - RFE: rpm -V no md5 option
Summary: RFE: rpm -V no md5 option
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-28 20:38 UTC by dmetz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-05 14:16:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dmetz 2000-07-28 20:38:46 UTC
I'l like to see an option to disable the md5 portion of the `rpm -V' cmd.

I routinely use `rpm -V' with a perl filter to check the integrity of
installed rpms.
By sacrificing the thoroughness of the md5 check in a non-hostile
environment 
performance of this check can be improved to make it a much more useful
tool.

Derald
dmetz@remotesensing.org

Comment 1 Jeff Johnson 2000-07-31 15:27:34 UTC
Agreed that  "rpm -V" output would be enhanced by finer-grained control over
each of
the verification checks independently. Howvere, since rpm has far too many
confusing
command line options as it is, I believe that adding, say, 10 or so new command
line
options to enable/disable each of the verification checks independently is not
needed
at this time (hence I'm marking the request DEFERRED).

Meanwhile, it ain't hard to filter rpm -V output , removing the MD5 changed
indicator,
if that's your pleasure.

Comment 2 Jeff Johnson 2000-10-10 21:23:40 UTC
rpm already has --nomd5 in verify mode to disable file md5 sum verification.


Note You need to log in before you can comment on or make changes to this bug.