Bug 1483659 - Running bundle install breaks appliance
Summary: Running bundle install breaks appliance
Keywords:
Status: CLOSED DUPLICATE of bug 1414815
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.8.0
Hardware: All
OS: All
medium
high
Target Milestone: GA
: cfme-future
Assignee: Gregg Tanzillo
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-21 16:06 UTC by Ryan Spagnola
Modified: 2020-12-14 09:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-27 21:05:06 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Ryan Spagnola 2017-08-21 16:06:42 UTC
Description of problem:
Running bundle install breaks an appliance's gems.
Minimal success in re-installing gemset rpm.

Version-Release number of selected component (if applicable):
Any

How reproducible:
Always

Steps to Reproduce:
1. Run bundle install
2. reboot appliance
3. Not able to use appliance_console or UI

Actual results:


Expected results:


Additional info:
Would it be possible to put in place a version blocker for gems to avoid this?

Only fix found so far is to export database and deploy a new appliance and import previous database

Comment 3 Joe Rafaniello 2018-02-27 21:05:06 UTC
Unfortunately, no, you can't run bundle install or bundle or bundle update on downstream appliances due to downstream packaging:

a) scl ruby changes bundler/rubygems (library locations, etc.)
b) downstream packaging of gems puts libraries into multiple locations

Since bundle --frozen option doesn't work as we'd like, the only recourse would be to provide our own bundle command that prevents you from running it.  I don't know if that's better.

We're hoping to no longer use scl ruby in the future and perhaps this would allow us to properly use the --frozen option.

*** This bug has been marked as a duplicate of bug 1414815 ***


Note You need to log in before you can comment on or make changes to this bug.