Bug 14843 - rc.sysinit tries to fsck / even if it is on NFS.
Summary: rc.sysinit tries to fsck / even if it is on NFS.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-29 23:55 UTC by Aleksey Nogin
Modified: 2014-03-17 02:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 22:33:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for detecting / on an NFS mounted file system (339 bytes, patch)
2002-11-20 20:24 UTC, david d zuhn
no flags Details | Diff

Description Aleksey Nogin 2000-07-29 23:55:51 UTC
In root-over-NFS setup, rc.sysinit still tries to fsck /. Ideally, it
should check whether / is something that fsck is capable of checking before
running fsck... It is a minor problem since it only results in error
message being printed.

Comment 1 Bill Nottingham 2000-07-31 20:16:40 UTC
Fixed in initscripts-5.40-1. Thanks for the bug report!


Comment 2 Aleksey Nogin 2002-10-23 12:07:31 UTC
This bug is back in Psyche!

Comment 3 Bill Nottingham 2002-10-23 15:02:16 UTC
Yeah, this got reported internally as well.

Comment 4 david d zuhn 2002-11-20 20:24:50 UTC
Created attachment 85752 [details]
fix for detecting / on an NFS mounted file system

Comment 5 david d zuhn 2002-11-20 20:27:53 UTC
There are two entries in /proc/mounts for an NFS mounted root filesystem:

rootfs / rootfs rw 0 0
/dev/root / nfs ro,v2,rsize=4096,wsize=4096,hard,udp,nolock,addr=10.0.0.171 0 0

The patch I attached is what we use in house for managing root NFS filesystems.
We're only interested in the non-rootfs entry for /.

Comment 6 Bill Nottingham 2003-01-24 22:33:01 UTC
Fixed in 7.05-1.


Note You need to log in before you can comment on or make changes to this bug.