Bug 14871 - Fail to kill process during system shutdown
Summary: Fail to kill process during system shutdown
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-31 06:50 UTC by Need Real Name
Modified: 2014-03-17 02:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-31 06:50:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-07-31 06:50:20 UTC
when I try "init 6" or select "reboot/halt" from the login screen for
shutdown, the system fail to stop all the process(named, sendmail, httpd
...etc), I have try to restart some process manually, (e.g.
/etc/rc.d/init.d/named restart), I can make surely that the process is
killed, but the system can't return a true to the script, it show up a
messages as below :

Shutting down named: kill: (1415) - No such pid
							[FAILED]
Starting namd:						[  OK  ]

But i have check the pid for named before kill, it's 1415, when the above
process finish, pid 1415 is gone.

thanks for your kindly attention and help

Comment 1 Bill Nottingham 2000-08-07 04:52:42 UTC
We can't reproduce this in testing here. Please re-open
if this persists, and if you could provide more info
on how to reproduce this, it would be helpful.


Note You need to log in before you can comment on or make changes to this bug.