Bug 1487398 - 7Server EUS repositories only see RHEL 7.2 kernels
Summary: 7Server EUS repositories only see RHEL 7.2 kernels
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: pre-dev-freeze
: ---
Assignee: John Francini
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-31 18:51 UTC by dyuen
Modified: 2020-12-14 09:49 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-21 16:46:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description dyuen 2017-08-31 18:51:13 UTC
Description of problem:
Customer questioning why Satellite 6.2 repos - Red Hat Enterprise Linux 7 Server - Extended Update Support RPMs x86_64 7Server only see RHEL 7.2 kernels. i.e. 3.10.0-327.X.Y.  Repo contain less packages compare to other EUS repo.

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:
Run some test on Satellite 6.2.11 test system:
-Add new product and sync
  -Red Hat Enterprise Linux 7 Server - Extended Update Support RPMs x86_64 7.3
  -Red Hat Enterprise Linux 7 Server - Extended Update Support RPMs x86_64 7.4  
  -Red Hat Enterprise Linux 7 Server - Extended Update Support RPMs x86_64 7Server

Satellite web UI
  -Content --> Packages

    Red Hat Enterprise Linux 7 Server - Extended Update Support RPMs x86_64 7Server -- kernel --> Search
    -- Latest kernel --> kernel-3.10.0-327.58.1.el7

    Red Hat Enterprise Linux 7 Server - Extended Update Support RPMs x86_64 7.3 -- kernel --> Search
    -- Latest kernel --> kernel-3.10.0-514.28.1.el7
                         kernel-3.10.0-327.36.3.el7

    Red Hat Enterprise Linux 7 Server - Extended Update Support RPMs x86_64 7.4 -- kernel --> Search           
    -- Latest kernel --> kernel-3.10.0-693.1.1.el7
                         kernel-3.10.0-514.26.2.el7
                         kernel-3.10.0-327.36.3.el7

   Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server
   -- Latest kernel --> kernel-3.10.0-693.1.1.el7
                        kernel-3.10.0-514.26.2.el7
                        kernel-3.10.0-327.36.3.el7

Actual results:
Not able to find any RHEL7.3/7.4 kernel packages in 7Server EUS.

Expected results:
Not just 7.2 kernel packages

Additional info:

Comment 4 Lubos Kocman 2017-09-29 08:19:31 UTC
This is most likely caused by the fact that symlink for EUS wasn't bumped

Lubos

Comment 6 John Francini 2017-10-26 17:23:50 UTC
EUS is versioned. The customer should not be using the 7Server repositories; rather s/he should be using the 7.4 versioned repositories instead.  No current content is pushed into the 7Server repositories for EUS, AUS, TUS, E4S, or any other extended support option. Their continued existence is in error, and they will be eventually removed.

Comment 10 Jenny Severance 2017-11-03 13:00:38 UTC
Hi Jan,
We can not do regression testing because we have no source of truth to tell us what "should" be in a given repo at any given time.  Integrated CAT testing on initial push of advisory content is all we can do.  My suggestion ..

1) Determine the exact kernel packages that you believe are missing
2) Find the exact advisories in ET that were to deliver that content
3) Verify that the advisory was configured to deliver that kernel to that repo from the builds and content tabs.
4) If so - reschedule CAT testing to see what the results are now.

If you can give me the exact kernel versions that you believe are missing and the associated advisories, I can do this for you.
Thanks
Jenny

Comment 12 Jenny Severance 2017-11-03 14:19:18 UTC
I can't grant ack because CAT testing is passing and did pass on at least the advisory that I found.

Comment 15 John Francini 2018-02-21 16:46:50 UTC
Closing as NOT A BUG.


Note You need to log in before you can comment on or make changes to this bug.