Bug 148758 - Files in /etc/logrotate.d/ does not read global configuration due to misleading comment in /etc/logrotate.conf
Summary: Files in /etc/logrotate.d/ does not read global configuration due to misleadi...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: logrotate   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-15 12:33 UTC by Oliver Schulze L.
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-16 10:12:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Oliver Schulze L. 2005-02-15 12:33:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
In logrotate.conf there is a comment that reads:
"# system-specific logs may be also be configured here."

So you need to put there your global-custom configurations.

But, the problem is that before that comment line, all files in
/etc/logrotate.d/*
are executed without that "global-custom" configuration that you
configured.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. put: "mail root@localhost" after the comment "# system-specific
logs may be also be configured here."
2. run logrotate in debug mode: logorate /-d etc/logrotate.conf
3. check that old logs are not mailed to root
4. now put "mail root@localhost" before the line: "# RPM packages drop
log rotation information into this directory"
5. run again "logorate /-d etc/logrotate.conf" and check that old logs
are mailed to root
    

Actual Results:  Files in /etc/logrotate.d/* does not use global
configurations from /etc/logrotate.conf

Expected Results:  Files in /etc/logrotate.conf should use global
configurations from /etc/logrotate.conf

Additional info:

Asolution should be something like this:
/etc/logrotate.conf:
...

# system-specific logs may be also be configured here.


# RPM packages drop log rotation information into this directory
include /etc/logrotate.d

EOF

Comment 1 Peter Vrabec 2005-02-16 10:12:45 UTC
I think "# system-specific logs may be also be configured here." means this is a
place for custom configurations of custom specified logs.


Comment 2 Oliver Schulze L. 2005-02-17 20:08:28 UTC
The problem I found, is that this comment:
"# system-specific logs may be also be configured here."
mislead users to think that there is a place to put global options.

I think it would be nice if there could be a comment that says:
"# Global options may be configured here"

There order of the statements in logrotate.conf changed when the line:
"include /etc/logrotate.d/"
was intruduced. Before that, users of RedHat 6.x to 9 have been putting global
options after:
"# system-specific logs may be also be configured here."

So, if the place for global options has changed, there could be at least a
comment for documenting that.

Thanks



Note You need to log in before you can comment on or make changes to this bug.