Bug 1487606 - The python2-urllib3.noarch 1.20-1.fc26 will not update.
Summary: The python2-urllib3.noarch 1.20-1.fc26 will not update.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python-urllib3
Version: 26
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Fedora Infrastructure SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-01 11:38 UTC by Lukas Ruzicka
Modified: 2017-09-05 13:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-05 13:52:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Ruzicka 2017-09-01 11:38:51 UTC
Description of problem:

When upgrading the Fedora 26 system with:

sudo dnf upgrade

the upgrading process ends up with a warning (I had to translate the strings from Czech to English, so maybe they will not be accurate but it should give you a notion of what the problem is):

Downloading packages:
python2-urllib3-1.20-1.fc26.noarch.r 650 kB/s | 149 kB     00:00    
---------------------------------------------------------------------
Total                               106 kB/s | 149 kB     00:01     
Checking transaction.
Transaction check was successful.
Transaction test running.
Transaction test was successful.
Transaction running
  Getting ready        :                                              1/1 
  Upgrading     : python2-urllib3-1.20-1.fc26.noarch           1/2 
Error unpacking rpm package python2-urllib3-1.20-1.fc26.noarch
Error unpacking rpm package python2-urllib3-1.20-1.fc26.noarch
Error: Unpacking of the archive failed on file /usr/lib/python2.7/site-packages/urllib3/packages/ssl_match_hostname: cpio: rename
python2-urllib3-1.20-1.fc26.noarch should be installed, but is not!
  Checking         : python2-urllib3-1.20-1.fc26.noarch           1/2 
python2-urllib3-1.15.1-3.fc25.noarch should be removed, but is not!
  Checking         : python2-urllib3-1.15.1-3.fc25.noarch         2/2 

Failed:
  python2-urllib3.noarch 1.20-1.fc26

Comment 1 Jeremy Cline 2017-09-05 13:52:10 UTC
Hi,

I think you accidentally marked this bug as private.

This happens when you ``sudo pip install`` a package since it installs to the same directory as the RPM versions and they conflict. You'll need to remove the pip-installed version and do a reinstall from the RPM to update.


Note You need to log in before you can comment on or make changes to this bug.