Bug 14878 - cciss driver is missing
cciss driver is missing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Winston rc1
:
Depends On:
Blocks: 15197
  Show dependency treegraph
 
Reported: 2000-07-31 10:44 EDT by John Cagle
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 20:58:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Cagle 2000-07-31 10:44:56 EDT
Charles White sent this new driver to Doug Ledford to be included in 7.0.
Comment 1 Michael K. Johnson 2000-08-03 10:17:42 EDT
Could you send it to me?  Doug's a little behind and I'm
helping him try to catch up.
Comment 2 John Cagle 2000-08-03 12:18:03 EDT
I will send it this afternoon.  It will be a kernel patch and a
minor LILO patch to support booting from the array.
Thanks!
Comment 3 Glen Foster 2000-08-04 10:44:53 EDT
This defect is considered MUST-FIX for Winston Release-Candidate #1
Comment 4 Michael K. Johnson 2000-08-04 11:47:47 EDT
I did not receive this driver yesterday, could you
please (re-)send?
Comment 5 Michael K. Johnson 2000-08-04 12:32:10 EDT
OK, added to current kernel source, was already in lilo
Comment 6 Matt Wilson 2000-08-04 15:38:35 EDT
Done in CVS.
Comment 7 Michael K. Johnson 2000-08-07 14:46:14 EDT
Unless an official major number assignment is made for
this driver and that fact communicated to us, we will
have to remove the driver from the distribution.  This
needs to happen ASAP, probably today in order for any
real testing.
Comment 8 John Cagle 2000-08-07 16:31:47 EDT
Below is a thread of email between myself and H. Peter Anvin (hpa@transmeta.com)
related to the use of several ranges of addresses, including the cciss
driver.

In this thread, Mr. Anvin approve's the use of this range for the
cciss driver:

130 block       Compaq Next Generation Drive Array (First Controller)
                  0 = /dev/cciss/c0d0   First Logical Drive (#1)
                  1 = /dev/cciss/c0d0p1 First Partition of First Drive
                    ...
                 15 = /dev/cciss/c0d0p15 Last Partition of First Drive

                ...

                240 = /dev/cciss/c0d15  Last Logical Drive (#15)
                241 = /dev/cciss/c0d15p1 First Partition of Last Drive
                    ...
                255 = /dev/cciss/c0d15p15 Last Partition of Last Drive

131 block       Compaq Next Generation Drive Array (Second Controller)
                  0 = /dev/cciss/c1d0   First Logical Drive (#1)
                Remaining Logical Drives and Partitions are handled just
                like the first controller (See major number 130).

132 block       Compaq Next Generation Drive Array (Third Controller)
                  0 = /dev/cciss/c2d0   First Logical Drive (#1)
                Remaining Logical Drives and Partitions are handled just
                like the first controller (See major number 130).

133 block       Compaq Next Generation Drive Array (Fourth Controller)
                  0 = /dev/cciss/c3d0   First Logical Drive (#1)
                Remaining Logical Drives and Partitions are handled just
                like the first controller (See major number 130).

134 block       Compaq Next Generation Drive Array (Fifth Controller)
                  0 = /dev/cciss/c4d0   First Logical Drive (#1)
                Remaining Logical Drives and Partitions are handled just
                like the first controller (See major number 130).

135 block       Compaq Next Generation Drive Array (Sixth Controller)
                  0 = /dev/cciss/c5d0   First Logical Drive (#1)
                Remaining Logical Drives and Partitions are handled just
                like the first controller (See major number 130).

136 block       Compaq Next Generation Drive Array (Seventh Controller)
                  0 = /dev/cciss/c6d0   First Logical Drive (#1)
                Remaining Logical Drives and Partitions are handled just
                like the first controller (See major number 130).

137 block       Compaq Next Generation Drive Array (Eighth Controller)
                  0 = /dev/cciss/c7d0   First Logical Drive (#1)
                Remaining Logical Drives and Partitions are handled just
                like the first controller (See major number 130).

Here's his most recent email:

Received: from tazenda.transmeta.com (root@tazenda.transmeta.com [10.8.144.6])
	by deepthought.transmeta.com (8.9.3/8.9.3) with ESMTP id SAA25083
	for <John.Cagle@compaq.com>; Sun, 16 Jul 2000 18:13:03 -0700 (PDT)
Received: from transmeta.com (hpa@localhost [127.0.0.1]) by tazenda.transmeta.com (8.9.3/8.7.3) with ESMTP id SAA03480 for 
<John.Cagle@compaq.com>; Sun, 16 Jul 2000 18:13:02 -0700
Sender: hpa@transmeta.com
Message-ID: <39725D9E.167D08C2@transmeta.com>
Date: Sun, 16 Jul 2000 18:13:02 -0700
From: "H. Peter Anvin" <hpa@transmeta.com>
Organization: Transmeta Corporation
To: "Cagle, John" <John.Cagle@compaq.com>
Subject: Re: new device number request - devices.txt

"Cagle, John" wrote:
> >
> > Please don't squat device numbers like that.  Your block of 8 isn't
> > aligned, which is a problem for device number migration.  I would like
> > to reallocate you to the block 104-111.  Please let me know if that is
> > OK, and if not, realize that this is your screwup, not mine.
> 
> I realized we were squatting, and that's why I wanted to get 'legal'.  (I'm
> not the developer of these drivers.)  Chris Frantz was the cpqarray
> developer, and I believe he communicated closely with Linus during his
> development.  It was an honest oversight.  I spoke with the developers of
> the cciss drivers, and they were not aware they needed to get properly
> allocated device numbers, claiming that they simply followed the
> instructions in the Linux Device Drivers book...
> 
> Since these drivers are currently in use, do you mind too much if we keep
> these device numbers?
> 

**********************************************************************
I guess it's ok.  I can't say I'm pleased with it, but can't really
think it being such a big deal.
**********************************************************************

[other requests deleted]

	-hpa

-- 
<hpa@transmeta.com> at work, <hpa@zytor.com> in private!
"Unix gives you enough rope to shoot yourself in the foot."
http://www.zytor.com/~hpa/puzzle.txt

Here's his FIRST RESPONSE:
--------------------------------------------
"Cagle, John" wrote:
> 
> Dear Mr. Anvin,
> 
> I am writing to you today for two purposes.  First, I would like to supply
> you with some missing information regarding the cpqarray (which is in the
> current Linux kernel) and cciss drivers (soon to be included in the kernel).
> Secondly, I'd like to request two additional major numbers for some work we
> have in progress.
> 
> First, here are the missing block devices that are used by the existing
> cpqarray and cciss drivers, which support up to eight controllers each in
> one system:

Please don't squat device numbers like that.  Your block of 8 isn't
aligned, which is a problem for device number migration.  I would like
to reallocate you to the block 104-111.  Please let me know if that is
OK, and if not, realize that this is your screwup, not mine.

> 
> ==================================================================
>  72 block       Compaq Intelligent Drive Array (First Controller)
>                   0 = /dev/ida/c0d0     First Logical Drive (#1)
>                   1 = /dev/ida/c0d0p1   First Partition of First Drive
>                     ...
>                  15 = /dev/ida/c0d0p15  Last Partition of First Drive
> 
>                 ...
> 
>                 240 = /dev/ida/c0d15    Last Logical Drive (#15)
>                 241 = /dev/ida/c0d15p1  First Partition of Last Drive
>                     ...
>                 255 = /dev/ida/c0d15p15 Last Partition of Last Drive
> 
>  73 block       Compaq Intelligent Drive Array (Second Controller)
>                   0 = /dev/ida/c1d0     First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 72).
> 
>  74 block       Compaq Intelligent Drive Array (Third Controller)
>                   0 = /dev/ida/c2d0     First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 72).
> 
>  75 block       Compaq Intelligent Drive Array (Fourth Controller)
>                   0 = /dev/ida/c3d0     First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 72).
> 
>  76 block       Compaq Intelligent Drive Array (Fifth Controller)
>                   0 = /dev/ida/c4d0     First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 72).
> 
>  77 block       Compaq Intelligent Drive Array (Sixth Controller)
>                   0 = /dev/ida/c5d0     First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 72).
> 
>  78 block       Compaq Intelligent Drive Array (Seventh Controller)
>                   0 = /dev/ida/c6d0     First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 72).
> 
>  79 block       Compaq Intelligent Drive Array (Eighth Controller)
>                   0 = /dev/ida/c7d0     First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 72).
> 
> ------------------------------------------------------------------
> 
> 130 block       Compaq Next Generation Drive Array (First Controller)
>                   0 = /dev/cciss/c0d0   First Logical Drive (#1)
>                   1 = /dev/cciss/c0d0p1 First Partition of First Drive
>                     ...
>                  15 = /dev/cciss/c0d0p15        Last Partition of First
> Drive
> 
>                 ...
> 
>                 240 = /dev/cciss/c0d15  Last Logical Drive (#15)
>                 241 = /dev/cciss/c0d15p1        First Partition of Last
> Drive
>                     ...
>                 255 = /dev/cciss/c0d15p15       Last Partition of Last Drive
> 
> 131 block       Compaq Next Generation Drive Array (Second Controller)
>                   0 = /dev/cciss/c1d0   First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 130).
> 
> 132 block       Compaq Next Generation Drive Array (Third Controller)
>                   0 = /dev/cciss/c2d0   First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 130).
> 
> 133 block       Compaq Next Generation Drive Array (Fourth Controller)
>                   0 = /dev/cciss/c3d0   First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 130).
> 
> 134 block       Compaq Next Generation Drive Array (Fifth Controller)
>                   0 = /dev/cciss/c4d0   First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 130).
> 
> 135 block       Compaq Next Generation Drive Array (Sixth Controller)
>                   0 = /dev/cciss/c5d0   First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 130).
> 
> 136 block       Compaq Next Generation Drive Array (Seventh Controller)
>                   0 = /dev/cciss/c6d0   First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 130).
> 
> 137 block       Compaq Next Generation Drive Array (Eighth Controller)
>                   0 = /dev/cciss/c7d0   First Logical Drive (#1)
>                 Remaining Logical Drives and Partitions are handled just
>                 like the first controller (See major number 130).
> 
> ==================================================================

[other requests deleted]

	-hpa

-- 
<hpa@transmeta.com> at work, <hpa@zytor.com> in private!
"Unix gives you enough rope to shoot yourself in the foot."
http://www.zytor.com/~hpa/puzzle.txt
Comment 9 Michael K. Johnson 2000-08-07 16:39:35 EDT
Thank you very much for resolving this as quickly as
possible!  The driver is in...  Also, as was requested
of Alan, I incremented the version number of the driver
to 1.0.0 while applying the patch he created.
Comment 10 Michael K. Johnson 2000-08-07 17:22:31 EDT
Oh, dear, Alan says there's more to it.  I'll take my
foot out of my mouth and wait for Alan to say what to
do here.
Comment 11 John Cagle 2000-08-07 19:20:00 EDT
EMAIL TO ALAN:
Alan,

If you'd like to change the cciss major device numbers from
[130..137] to [104..111], we won't mind.  However, we are
concerned about the amount of testing that we'll be able
to perform with the new driver.  All of our storage staff
will be at LinuxWorld Expo next week, so if you decide to
change it, please consider giving us a patch or kernel RPM
so that we can start testing it this week (instead of
waiting for RC1).

Also, don't forget to change the cciss major numbers in all
of the following places:

 1) include/linux/major.h (in /usr/include/linux)
 2) Documentation/mkdev.cciss
 3) Documentation/cciss.txt
 4) LILO's lilo.h
 5) installer/anaconda??

Please let me know when a patch is available and I'll send
it to our storage people.

Cheers,
John Cagle
Comment 12 Michael K. Johnson 2000-08-07 21:03:29 EDT
Ahhhhh!  Finally closed this bug, for (touch wood) the
last time.  We have changed the driver's major numbers
and sent the patch to Compaq.  Bugs are filed against
the components that need to be changed to accomodate
this change.

Note You need to log in before you can comment on or make changes to this bug.