Bug 148910 - LTC18619- Javaws dont work/cant start
Summary: LTC18619- Javaws dont work/cant start
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: java-1.4.2-ibm (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Keywords:
: davemcp (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-16 21:09 UTC by Bjorn Ryborg
Modified: 2007-11-30 22:07 UTC (History)
7 users (show)

Fixed In Version: 1.4.2.6-1jpp.2.el4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 18:19:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bjorn Ryborg 2005-02-16 21:09:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; da-DK; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
The IBM version of java 1.4.2 cant start javaws. Not from firefox browser and not from Terminal.

Version-Release number of selected component (if applicable):
java-1.4.2-ibm-1.4.2.1-1jpp_2rh java-1.4.2-ibm-plugin-1.4.2.1-1jpp_2rh

How reproducible:
Always

Steps to Reproduce:
1.Install java-1.4.2-ibm-1.4.2.1-1jpp_2rh
2.Install java-1.4.2-ibm-plugin-1.4.2.1-1jpp_2rh
3.Try lunch the javaws
  

Additional info:

Comment 2 Thomas Fitzsimmons 2005-02-18 18:03:03 UTC
I've reported this problem to IBM.


Comment 3 Daniel Riek 2005-02-23 11:15:40 UTC
I am seeing this problem also with the Bea jdk 1.4.2.

Possible workaround: The RHEL3 java-1.4.1-ibm package for me works correctly on
RHEL4.

Comment 4 Thomas Fitzsimmons 2005-03-09 18:46:41 UTC
*** Bug 150684 has been marked as a duplicate of this bug. ***

Comment 5 jordan hargrave 2005-04-19 21:30:49 UTC
I just found this. Looks like it is a known problem.
http://bugs.sun.com/bugdatabase/view_bug.do;:YfiG?bug_id=6195591

And there is a fix:
http://www.jbg.f2s.com/javaws-1_2_0_06-linux-i586-i.zip

Comment 6 Dave McPherson 2005-04-19 21:35:31 UTC
That's all fine and good but there are applications that require 1.4.2 or 
better (sun is now on 1.5). And 1.4.2 works fine on RHEL3 but not RHEL4, looks 
like a step back to me.

Comment 7 mark wisner 2005-09-23 14:33:24 UTC
please post the results from the java -version.

Comment 8 Panu Matilainen 2005-09-26 06:58:41 UTC
[pmatilai@esdhc939-17773 ~]$ java -version
java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2)
Classic VM (build 1.4.2, J2RE 1.4.2 IBM build cxia32142-20041210 (JIT enabled:
jitc))

Oh and here's a nicer workaround, tried it and seems to work (that is, at least
javaws starts): http://www.advogato.org/person/rmathew/diary.html?start=71

Comment 9 IBM Bug Proxy 2005-09-26 15:20:16 UTC
---- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2005-09-26 11:16 EDT -------
I reported the bug to IBM Java support via our internal reporting system. The
generated PMR # is 93656,001,866. 

Comment 10 IBM Bug Proxy 2005-09-27 21:11:13 UTC
---- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2005-09-27 17:06 EDT -------
IBM Java support raised a request with Sun for source diffs in regards to this
defect. 

Comment 11 IBM Bug Proxy 2005-09-30 13:46:16 UTC
---- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2005-09-30 09:43 EDT -------
I had an update from Java support:

\"We were not able to recreate this problem, with
the latest 142 sr2 JDK on RHEL 4. Provide us sequence
of steps how to recreate this problem.
Sun bug 6195591 might be specific to there implementation.
Action Plan :
Provide us sequence of steps to recreate this problem.\"

So, it appears that the java version being used is fairly old now. The upcoming
RHEL 4 U2 service update contains the mentioned Java 1.4.2 SR2 (service release
2). Can you please give that a try and if that still does not help, please
provide more detailed recreation steps? Thanks. 

Comment 12 Panu Matilainen 2005-10-03 11:03:25 UTC
Yup, the java package (java-1.4.2-ibm-1.4.2.2-1jpp_10rh) from RHEL 4 Extras Beta
appears to fix this issue.

Comment 13 IBM Bug Proxy 2005-10-03 14:07:13 UTC
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ACCEPTED                    |CLOSED
             Impact|------                      |Usability




------- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2005-10-03 10:03 EDT -------
Thanks for the quick feedback! Closing bug as FIX_ALREADY_AVAIL. 

Comment 14 mark wisner 2006-04-05 16:29:14 UTC
This is fixed in U3.


Note You need to log in before you can comment on or make changes to this bug.