Bug 148922 - Error messages during upgrade from RHEL 4 to RHEL 4 U1
Error messages during upgrade from RHEL 4 to RHEL 4 U1
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.1
ia32e Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-16 17:42 EST by H.J. Lu
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-01 17:58:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-ks.cfg (1.42 KB, text/plain)
2005-02-21 12:04 EST, H.J. Lu
no flags Details
install.log (35.90 KB, text/plain)
2005-02-21 12:05 EST, H.J. Lu
no flags Details

  None (edit)
Description H.J. Lu 2005-02-16 17:42:24 EST
I got

Upgrading firefox-1.0-12.EL4.x86_64.
error: %post(firefox-1.0-12.EL4.x86_64) scriptlet failed, exit status 255
Upgrading iiimf-x-12.1-10.EL.x86_64.
error: %post(iiimf-x-12.1-10.EL.x86_64) scriptlet failed, exit status 255
Upgrading iiimf-gtk-12.1-10.EL.x86_64.
error: %post(iiimf-gtk-12.1-10.EL.x86_64) scriptlet failed, exit
status 255
Upgrading system-switch-im-0.1.2-3.noarch.
Upgrading iiimf-le-chinput-0.3-16.x86_64.
error: %post(iiimf-le-chinput-0.3-16.x86_64) scriptlet failed, exit
status 255
Upgrading iiimf-le-xcin-0.1.7-11.x86_64.
error: %post(iiimf-le-xcin-0.1.7-11.x86_64) scriptlet failed, exit
status 255
Upgrading iiimf-gnome-im-switcher-12.1-10.EL.x86_64.
error: %post(iiimf-gnome-im-switcher-12.1-10.EL.x86_64) scriptlet
failed, exit status 255

when I was upgrading from RHEL 4 RC to RHEL4 on EM64T. Passing
"selinux=0" to kernel seems to fix the problem.
Comment 1 Jeremy Katz 2005-02-16 22:27:05 EST
Upgrades between beta releases are not supported.
Comment 2 H.J. Lu 2005-02-17 12:38:31 EST
Those messages also happened to upgrading from RHEL 3 U4:

Upgrading libgcc-3.4.3-9.EL4.i386.
error: %post(libgcc-3.4.3-9.EL4.i386) scriptlet failed, exit status 255
Upgrading glibc-2.3.4-2.i686.
warning: /etc/ld.so.conf created as /etc/ld.so.conf.rpmnew
error: %postun(glibc-2.3.2-95.30.i686) scriptlet failed, exit status 255
error: %trigger(redhat-lsb-1.3-3.1.EL3.i386) scriptlet failed, exit
status 255
error: %trigger(redhat-lsb-1.3-3.1.EL3.x86_64) scriptlet failed, exit
status 255Upgrading glibc-2.3.4-2.x86_64.
warning: /etc/ld.so.conf created as /etc/ld.so.conf.rpmnew
error: %trigger(redhat-lsb-1.3-3.1.EL3.i386) scriptlet failed, exit
status 255
error: %trigger(redhat-lsb-1.3-3.1.EL3.x86_64) scriptlet failed, exit
status 255
Comment 3 Jeremy Katz 2005-02-20 15:38:24 EST
Can you provide the complete /root/install.log from your rhel3 install
plus /root/upgrade.log from after the upgrade as well as
/var/log/anaconda*
Comment 4 H.J. Lu 2005-02-21 12:03:55 EST
I will upload /root/install.log and /root/anaconda-ks.cfg.
/root/upgrade.log and /var/log/anaconda* are generated when booting
kernel with "selinux=0" after I saw those messages in upgrade.log.
They are quite normal now. I can upload them if you still want them.
Comment 5 H.J. Lu 2005-02-21 12:04:52 EST
Created attachment 111263 [details]
anaconda-ks.cfg
Comment 6 H.J. Lu 2005-02-21 12:05:20 EST
Created attachment 111264 [details]
install.log
Comment 7 H.J. Lu 2005-07-29 17:14:42 EDT
I got the same problem when uprading from RHEL 4 to RHEL 4 U1 on ia32 and EM64T.
As the result, some rpms weren't upgraded. I had to run the upgrade process
the second time, passing "selinux=0" to kernel.
Comment 8 Jeremy Katz 2005-08-01 17:58:41 EDT
Anaconda should not be used for upgrades except between releases -- going
between updates, you should use up2date.

Note You need to log in before you can comment on or make changes to this bug.