Bug 148937 - Patch to deactivate X11 support
Summary: Patch to deactivate X11 support
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-17 01:36 UTC by Philip Gwyn
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 19:06:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Philip Gwyn 2005-02-17 01:36:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040914

Description of problem:
This patch adds %define use_X to the spec file.  This define is then
used to conditionnaly turn functionnaly that needs X11 on or off.

Deactivating X11 is useful for servers.

ImageMagick with X11 removed won't have display(1).

Version-Release number of selected component (if applicable):
ImageMagick-6.0.7.1-4

How reproducible:
Always

Steps to Reproduce:
1. Default install of FC3
2. rpm -e xorg-x11-libs

    

Actual Results:  Step 2 fails because ImageMagick (amoungst others)
requires X11 libs.

Expected Results:  Being able to install a server w/o X11 libs.

Additional info:

diff -ub SPECS/ImageMagick.spec SPECS.noX/ImageMagick.spec
--- SPECS/ImageMagick.spec  2004-10-11 10:00:45.000000000 -0400
+++ SPECS.noX/ImageMagick.spec  2005-02-16 19:22:49.058795848 -0500
@@ -2,6 +2,10 @@
 # 5.4.0.3 is actually version 5.4.0, Patchlevel 3.
 %define VER 6.0.7 
 %define Patchlevel 1
+
+# set to 0 to exclude X bits  
+%define use_X 0
+
 Summary: An X application for displaying and manipulating images.
 Name: ImageMagick
 %if "%{Patchlevel}" != ""
@@ -9,7 +13,11 @@
 %else
 Version: %{VER}
 %endif
+%if %{use_X}
 Release: 4
+%else
+Release: 4.noX.2
+%if
 License: freeware
 Group: Applications/Multimedia
 %if "%{Patchlevel}" != ""
@@ -27,7 +35,7 @@
 Url: http://www.imagemagick.org/
 Buildroot: %{_tmppath}/%{name}-%{version}-root
 BuildPrereq: bzip2-devel, freetype-devel, libjpeg-devel, libpng-devel
-BuildPrereq: libtiff-devel, libungif-devel, zlib-devel, perl
+BuildPrereq: libtiff-devel, giflib-devel, zlib-devel, perl
 BuildRequires: freetype-devel >= 2.0.1
 BuildRequires: automake >= 1.7 autoconf >= 2.58 libtool >= 1.5
  
@@ -52,7 +60,9 @@
 Requires: ImageMagick = %{version}-%{release}, bzip2-devel,
freetype-devel 
 Requires: libjpeg-devel, libpng-devel, libtiff-devel, zlib-devel,
libxml2-devel
 Requires: libexif-devel
+%if %{use_X}
 Requires: XFree86-devel
+%endif
 
 %description devel
 Image-Magick-devel contains the static libraries and header files you'll
@@ -119,9 +129,14 @@
 aclocal
 automake || :
 autoconf || :
+%if %{use_X}
+   X_OPTS=--with-x
+%else
+   X_OPTS=--without-x
+%endif
 %configure --enable-shared \
            --with-perl \
-      --with-x \
+           $X_OPTS \
            --with-threads \
            --with-magick_plus_plus
 make

Comment 1 Mephisto 2005-05-01 10:37:33 UTC
I'd like to see ImageMagick being split in 2 packages: the command line utils
and the x11 based tools. I need ImageMagick on my server for php scripts with
image processing, but i dont want X11 installed on it. The latest ImageMagick
(6.2.2.0-1.fc3) makes it even worse by also requiring gtk2 (wtf?), cups-libs (a
printer on a web server...?), some font stuff, xorg-x11-xfs (a font server? what
do i need that for??), and more...

seems like i almost need a complete X install, just to use ImageMagick command
line tools...

Comment 2 Matthew Miller 2006-07-10 22:56:03 UTC
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!



Note You need to log in before you can comment on or make changes to this bug.