Bug 148944 - Upstream 3.0.2 released
Upstream 3.0.2 released
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-16 21:59 EST by Kenneth Porter
Modified: 2010-12-09 21:53 EST (History)
1 user (show)

See Also:
Fixed In Version: FC4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 17:00:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kenneth Porter 2005-02-16 21:59:23 EST
From the announcement:

  *** From dhcp-announce -- To unsubscribe, see the end of this
message. ***

ISC DHCP 3.0.2 is now available.  This release fixes a number of bugs
present in the previous (3.0.1) release of ISC DHCP, most notably a
few failover bugs, a protocol violation, and a significant repair to
the selection and allocation of expired/abandoned leases.  As this is a
maintenance release, no new features have been added.

A list of the changes in this release is included below.  For a complete
list of changes from any previous release, please consult the RELNOTES
file within the source distribution.


This release and its OpenPGP signature is available now from:

    ftp://ftp.isc.org/isc/dhcp/dhcp-3.0.2.tar.gz
    ftp://ftp.isc.org/isc/dhcp/dhcp-3.0.2.tar.gz.asc

ISC's Release Signing Key can be obtained at:

    http://www.isc.org/about/openpgp/


ISC is also proud to announce that DHCP Support Contracts are now
available directly from ISC.  For more information please visit the
following URL:

    http://www.isc.org/ops/support/


                        Changes since 3.0.2rc3

- A previously undocumented configuration directive, 'local-address',
  was documented in the dhcpd.conf manpage.

                        Changes since 3.0.2rc2

- Two varaibles introduced in 3.0.2b1 were used without being initialized
  in the case where neither the FILE nor SNAME fields were available for
  overloading.  This was repaired.

- A heretofore believed to be impossible corner case of the option
  overloading implementation turned out to be possible ("Unable to sort
  overloaded options after 10 tries.").  The implementation was reworked
  to consider the case of an option so large it would require more than
  three chunks to fit.

- Many other instances of variables being used without being initialized
  were repaired.

- An uninitialized variable in omapi_io_destroy() led to the discovery
  that this function may result in orphaned pointers (and hence, a memory
  leak).

                        Changes since 3.0.2rc1

- allocate_lease() was rewritten to repair a bug in which the server would
  try to allocate an ABANDONED lease when FREE leases were available.

                        Changes since 3.0.2b1

- Some dhcp-eval.5 manpage formatting was repaired.

                        Changes since 3.0.1

- A bug was fixed in the server's 'option overloading' implementation,
  where options loaded into the 'file' and 'sname' packet fields were
  not aligned precisely as rfc2131 dictates.

- The FreeBSD client script was changed to support the case where a domain
  name was not provided by the server.

- A memory leak in 'omshell' per each command line parsed was
  repaired, thanks to a patch from Jarkko Torppa.

- Log functions writing to stderr were adjusted to use the STDERR_FILENO
  system definition rather than '2'.  This is a no-op for 90% of
platforms.

- One call to trace_write_packet_iov() counted the number of io vectors
  incorrectly, causing inconsistent tracefiles.  This was fixed.

- Some expression parse failure memory leaks were closed.

- A host byte order problem in tracefiles was repaired.

- Pools configured in DHCPD for failover possessing permission lists that
  previously were assumed to not include dyanmic bootp clients are now
  a little more pessimistic.  The result is, dhcpd will nag you about just
  about most pools that possess a 'allow' statement with no 'deny' that
  would definitely match a dynamic bootp client.

- The 'ddns-update-style' configuration warning bit now insists that
  the configuration be globally scoped.

- Two memory leaks in dhclient were closed thanks to a patch from Felix
  Farkas.

- Some minor but excellently pedantic documentation errors were fixed
  thanks to a patch from Thomas Klausner.

- Bugs in operator precedence in executable statements have been repaired
  once again.  More legal syntaxes should be parsed legally.

- Failing to initialize a tracefile for any reason if a tracefile was
  specified is now a fatal error.  Thanks to a patch from Albert Herranz.

- Corrected a bug in which the number of leases transferred as calculated
  by the failover primary and sent to peers in POOLRESP responses may be
  incorrect.  This value is not believed to be used by other failover
  implementations, excepting perhaps as logged information.

- Corrected a bug in which 'dhcp_failover_send_poolresp()' was in fact
  sending POOLREQ messages instead of POOLRESP mesasges.  This message
  was essentially ignored since failover secondaries effectively do not
  respond to POOLREQ messages.

- Type definitions for various bitwidths of integers in the sunos5-5
  build of ISC DHCP have been fixed.  It should compile and run more
  easily when built in 64-bit for this platform.

- "allow known-clients;" is now a legal syntax, to avoid confusion.

- If one dhcp server chooses to 'load balance' a request to its failover
  peer, it first checks to see if it believes said peer has a free
  lease to allocate before ignoring the DISCOVER.

- log() was logging a work buffer, rather than the value returned by
  executing the statements configured by the user.  In some cases,
  the work buffer and the intended results were the same.  In some other
  cases, they were not.  This was fixed thanks to a patch from Gunnar
  Fjone and directconnect.no.

- Compiler warnings for some string type conversions was fixed, thanks
  to Andreas Gustafsson.

- The netbsd build environments were simplified to one, in which
  -Wconversion is not used, thanks to Andreas Gustafsson.

- How randomness in the backoff-cutoff dhclient configuration variable
  is implemented was better documented in the manpage, and the behaviour
  of dhclient in REQUEST timeout handling was changed to match that of
  DISCOVER timeout handling.

- Omapi was hardened against clients that pass in null values, thanks
  to a patch from Mark Jason Dominus.

- A bug was fixed in dhclient that kept it from doing client-side
  ddns updates.  Thanks to a patch from Andreas Gustafsson, which
  underwent some modification after review by Jason Vas Dias.

- Failover implementations disconnected due to the network between
  them (rather than one of the two shutting down) will now try to
  re-establish the failover connection every 5 seconds, rather than
  to simply try once and give up until one of them is restarted.
  Thanks to a patch from Ulf Ekberg from Infoblox, and field testing
  by Greger V. Teigre which led to an enhancement to it.

- A problem that kept DHCP Failover secondaries from tearing down
  ddns records was repaired.  Thanks to a patch from Ulf Ekberg from
  Infoblox.

- 64bit pointer sizes are detected properly on FreeBSD now.

- A bug was repaired where the DHCP server would leave stale references
  to host records on leases it once thought about offering to certain
  clients.  The result would be to apply host and 'known' scopes to the
  wrong clients (possibly denying booting).  NOTE:  The 'mis-host' patch
  that was being circulated as a workaround is not the way this bug was
  fixed.  If you were a victim of this bug in 3.0.1, you are cautioned
  to proceed carefully and see if it fixes your problem.

- A bug was repaired in the server's DHCPINFORM handling, where it
  tried to divine the client's address from the source packet and
  would get it wrong.  Thanks to Anshuman Singh Rawat.

- A log message was introduced to help illuminate the case where the
  server was unable to find a lease to assign to any BOOTP client.
  Thanks to Daniel Baker.

- A minor dhcpd.conf.5 manpage error was fixed.

-- 
David W. Hankins		"If you don't do it right the first time,
Software Engineer			you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins
-----------------------------------------------------------------------
To unsubscribe from this list, visit http://www.isc.org/dhcp-lists.html
or send mail to dhcp-announce-request@isc.org with the subject line of
'unsubscribe'.
-----------------------------------------------------------------------
Comment 1 Jason Vas Dias 2005-02-17 00:07:32 EST
Yes, I get these mails too - it's really not necessary to raise
bugzillas about this. dhcp-3.0.2rc3 is already in FC4, which differs
only in a documentation addendum .  Use dhcp-3.0.2rc3 until I submit
dhcp-3.0.2 tomorrow.
Comment 2 Kenneth Porter 2005-02-17 00:45:40 EST
Thanks. It's not clear to me if all RH packagers follow the
announcement lists for the packages they maintain, and sometimes it
seems like an update announcement isn't noticed. I'll try to remember
that DHCP is one of the packages that gets tracked well.

I didn't want to put a fire under your feet to get this out. Hence I
filed it as an enhancement, just so that it gets into the queue.
Comment 3 Jason Vas Dias 2005-02-25 15:01:37 EST
dhcp-3.0.2 is now in FC4.
Comment 4 Peter van Egdom 2005-07-29 17:00:46 EDT
Closing bug with resolution "CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.