Bug 148963 - error running splittree.py for DVD images
error running splittree.py for DVD images
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-17 08:49 EST by Gene Czarcinski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-20 15:40:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2005-02-17 08:49:05 EST
Description of problem:

Running:

[root@amber test]# splittree.py --arch=i386 \
--total-discs=2 --bin-discs=1 --src-discs=1 \
--release-string="Fedora Core 3" \
--pkgorderfile=/home/redhat/test/fc3/pkgfile \
--distdir=/home/redhat/test/fc3/i386/ \
--srcdir=/home/redhat/test/fc3/i386/SRPMS/ \
--productpath=Fedora

Trying to create two DVD images, I get:

du: cannot access `/home/redhat/test/fc3/i386/-disc0': No such file or
directoryTraceback (most recent call last):
  File "/usr/lib/anaconda-runtime/splittree.py", line 455, in ?
    logfile = timber.main()
  File "/usr/lib/anaconda-runtime/splittree.py", line 380, in main
    self.splitRPMS()
  File "/usr/lib/anaconda-runtime/splittree.py", line 287, in splitRPMS
    curused = self.getSize("%s-disc%s" % (self.dist_dir, disc),
blocksize=1)
  File "/usr/lib/anaconda-runtime/splittree.py", line 110, in getSize
    thesize = int(string.split(thesize)[0])
IndexError: list index out of range

wheres running splittree.py for the regular CD splitting with
--total-discs=8 --bin-discs=4 --src-discs=4 it runs fine and creats
the four binary and four SRPMS directory trees.
Comment 1 Jeremy Katz 2005-02-20 15:40:36 EST
splittree isn't intended for splitting into DVD images.

Note You need to log in before you can comment on or make changes to this bug.