Bug 148979 - salinfod terminates on valid error status
salinfod terminates on valid error status
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-utils (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Prarit Bhargava
Brian Brock
:
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-02-17 12:50 EST by Alex Williamson
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2005-749
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 13:26:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
same patch as attached to 156968 (same problem on RHEL3) (546 bytes, patch)
2005-05-06 11:54 EDT, Alex Williamson
no flags Details | Diff
Patch to salinfo.spec file (705 bytes, patch)
2005-06-30 08:28 EDT, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Alex Williamson 2005-02-17 12:50:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050206 Firefox/1.0 (Debian package 1.0+dfsg.1-5)

Description of problem:
sal_error_status::sal_error_status(uint64_t status)
{
  static const uint64_t STATUS_TYPE_MASK=0xff00;

  uint64_t type_bits=(status & STATUS_TYPE_MASK)>>STATUS_TYPE_SHIFT;
  if( (type_bits<=3 && type_bits!=1) || (type_bits>=10 && type_bits<=15) ||
      type_bits>26)
    throw sal_error_status_type_range();


The STATUS_TYPE_SHIFT (7) is wrong.  If type_bits is 3 or less, the first test is always true.  The SAL error type field is defined as bits 8-15 of the error status field, therefore STATUS_TYPE_SHIFT should be 8.

It would be nice if something caught the throw of sal_error_status_type_range instead of terminating the daemon.

It would be nice if the daemon respawned if it dies.

Version-Release number of selected component (if applicable):
kernel-utils-2.4-13.1.48

How reproducible:
Always

Steps to Reproduce:
1. Feed a ERR_INTERNAL into salinfod
2.
3.
  

Actual Results:  salinfod terminates

Expected Results:  normal processing of a valid log

Additional info:
Comment 2 Alex Williamson 2005-05-06 11:54:37 EDT
Created attachment 114084 [details]
same patch as attached to 156968 (same problem on RHEL3)
Comment 6 Prarit Bhargava 2005-06-29 11:43:35 EDT
Please be aware that I can no longer see PRIVATE comments. 
Comment 7 Prarit Bhargava 2005-06-30 08:28:05 EDT
Created attachment 116168 [details]
Patch to salinfo.spec file

This patch adds support to the salinfo.spec file for the
salinfod_shift_fix.patch.
Comment 9 Dave Jones 2005-08-15 14:36:45 EDT
*** Bug 156968 has been marked as a duplicate of this bug. ***
Comment 12 Red Hat Bugzilla 2005-10-05 13:26:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-749.html

Note You need to log in before you can comment on or make changes to this bug.