Bug 148981 - NETWORK tests reporting an ERROR
NETWORK tests reporting an ERROR
Status: CLOSED ERRATA
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: net (Show other bugs)
2
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Landry
Rob Landry
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-17 13:19 EST by Rick Hester
Modified: 2007-04-18 13:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 12:39:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
network tests when run from kickstart file generated by ispec (and modified for quotes and missing eth1 setup) (288.86 KB, text/plain)
2005-02-17 13:28 EST, Rick Hester
no flags Details
network tests when run from /usr/sbin/redhat-ready (173.30 KB, text/plain)
2005-02-17 13:29 EST, Rick Hester
no flags Details

  None (edit)
Description Rick Hester 2005-02-17 13:19:41 EST
Description of problem:
When running the network tests either from a ks file generated by
ispec or on by manually invoking redhat-ready, the network tests
report an error.

Two NICs are in the box - both have been setup for DHCP. See below 
for the ifconfig outputs.

Attaching the two packaged results files.

Version-Release number of selected component (if applicable):
 rhr2-rhel4-1.0-10.noarch.rpm

How reproducible:
Previous runs resulted in NETWORK [FAILED], but these last
two runs resulted in NETWORK [ERROR]  seems easy enough
to reproduce. I had suspected that the earlier failures were
due to not BOOTPROTO being set for eth1 so it never received
an IP.  Once I added BOOTPROTO=dhcp to ifcfg-eth1, I stared
getting these ERROR results.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
ifconfig output:
eth0      Link encap:Ethernet  HWaddr 00:30:6E:39:46:AE
          inet addr:10.101.0.62  Bcast:10.255.255.255  Mask:255.0.0.0
          inet6 addr: fe80::230:6eff:fe39:46ae/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13303411 errors:0 dropped:0 overruns:0 frame:0
          TX packets:84 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1063799095 (1014.5 MiB)  TX bytes:5736 (5.6 KiB)
          Interrupt:56

[root@lincoln ~]# ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:30:6E:39:C6:CD
          inet addr:10.100.100.59  Bcast:10.255.255.255  Mask:255.0.0.0
          inet6 addr: fe80::230:6eff:fe39:c6cd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:118593 errors:0 dropped:0 overruns:0 frame:0
          TX packets:49763661 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:8911495 (8.4 MiB)  TX bytes:75196814583 (70.0 GiB)

Server address:
wilson.rihes has address 10.74.38.1
Comment 1 Richard Li 2005-02-17 13:22:12 EST
Can you upload your output.log for NETWORK?

Also, the errata update for RHR (-14a) has bugfixes in NETWORK.
Comment 2 Rob Landry 2005-02-17 13:25:50 EST
Also, if you can start the network test with none of the interfaces
up; that can help in a multiple nic situation where both are attached
to the same network (the easiest to setup, but technically invalid if
they are both up at the same time) since the test will then properly
bring up one interface at a time and avoid having the network issues
from misdirecting traffic.
Comment 3 Rick Hester 2005-02-17 13:28:39 EST
Created attachment 111173 [details]
network tests when run from kickstart file generated by ispec (and modified for quotes and missing eth1 setup)
Comment 4 Rick Hester 2005-02-17 13:29:47 EST
Created attachment 111174 [details]
network tests when run from /usr/sbin/redhat-ready
Comment 5 Richard Li 2005-02-17 13:32:39 EST
the ispec quotes problem is also fixed in the errata. are these results RPMs you
are uploading that contain the output.log file?
Comment 6 Rick Hester 2005-02-17 14:08:49 EST
Richard,

those RPMs should have the output log in them
I'm assuming that the errata you refer to - RHR (14a)
is on RHN?

Rob,

I'll rerun the NETWORK test with both interfaces down.

Comment 7 Richard Li 2005-02-17 14:16:29 EST
Yes, the errata is on RHN.
Comment 8 Rick Hester 2005-02-18 19:46:10 EST
I haven't updated this because I have been getting very inconclusive
results.   First time I tried to run the tests with both interfaces
down, there were some "artifcacts" from previous tests that clouded
the results. So I cleand those and rebooted, but forgot that the 
install was from one of the ispec ks installs, so it came up and 
started running redhat-ready in init 4.  Since I didn't feel like 
I could stop it without leaving more artifacts, I let it run to 
completion.   This time the network test passed (puzzling since
I made no change to the eth interface status).  After that test 
completed, I got in a hurry and forgot to insure that both interfaces
were down.  Only one was.  But the test completed correctly.
Now I'm running again with both interfaces up.  But it is taking 
an abnormally longer time to complete (may be due to some network 
issues we have been experiencing).  

So, all that to tell you I can't conclusively attribe the failures
to interface status.  Still working on it - we have Monday off, so
it will be a while before I have another update.  

In the mean time, if you happen to notice anything funny in the 
logs that I've sent - please let me know.
Comment 9 Rob Landry 2005-04-14 14:02:51 EDT
Can we verify if -17beta (people.redhat.com/rlandry/rhr2/test) resolves this issue?
Comment 10 Rick Hester 2005-04-14 14:11:45 EDT
Rob,

Unfortunately, we're tied up testing beta 1 of RHEL4 U1 at the 
moment.  So, I won't be able to get to the -17 beta for a while.

The other challenge is that I was finding it difficult to reliably
reproduce this problem.  

I have some certs planed for release of RHEL4 U1, so I will try
this out then.  That may be the earliest I can get to it.

I did run into other networking issues and problems after reporting
this particular one.  I was able to work around those by using
a faster cert server as well as have both the cert target and
server connected to the same switch.   So my problems may have
been performance related.

Comment 11 Richard Li 2005-05-11 12:39:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-419.html

Note You need to log in before you can comment on or make changes to this bug.