Bug 1489839 - Text UI installation to .img reboots whole host system when canceled
Summary: Text UI installation to .img reboots whole host system when canceled
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1392968
TreeView+ depends on / blocked
 
Reported: 2017-09-08 12:55 UTC by Marek Hruscak
Modified: 2021-01-15 07:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-15 07:41:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marek Hruscak 2017-09-08 12:55:24 UTC
Description of problem:
Anaconda offers option to install system to .img . When starting such installation with --text option, and trying to cancel it before finish, it will reboot whole system.
Restart, which finishes installation is safe and only turn off installation window.
Also installation using GUI does not have such problem.

Version-Release number of selected component (if applicable):
RHEL-7.4RC
anaconda-21.48.22.121-1

How reproducible:
Always

Steps to Reproduce:
1. install anaconda package with -! yum install anaconda
2. create .img file for installation
2. start installation using 
-! anaconda --text --image ./<file.img> --repo=http://<repository>
3. after menu appears, hit "q" and confirm

Actual results:
Host system will reboot without warning

Expected results:
Host system should not be rebooted

Additional info:
Nice solution how to block reboot here: https://access.redhat.com/solutions/1580343

Comment 1 Marek Hruscak 2017-10-11 06:31:44 UTC
I figured out, that this happens also in GUI installation to image. Canceling installation will reboot whole system.

Comment 2 Martin Kolman 2017-10-30 17:02:52 UTC
Trying it out on a recent 7.5 nightly (anaconda 21.48.22.126-1) in a VM I was not able to reproduce the host reboot. What I did:

0. installed RHEL 7.5 nightly
1. logged in as root
2. created an empty image file:

fallocate -l 500M target.img

3. run installation to image:

anaconda --text --image ./target.img --repo=http://www.example.com

(I tried also with a valid repo URL, made no difference)

4. tried to quit the installation:
- in the initial ask-VNC screen
- on the summary hub

And I was not able to trigger the unexpected reboot.

Comment 4 RHEL Program Management 2021-01-15 07:41:54 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.


Note You need to log in before you can comment on or make changes to this bug.