Bug 149007 - Problem sending hardware profile
Problem sending hardware profile
Status: CLOSED DUPLICATE of bug 144704
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-17 16:35 EST by John Reiser
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-18 07:38:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2005-02-17 16:35:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
On Monday Feb.14 I had two systems registered with RHN: "taroon"
(RHEL3 WS for i386 with latest update) with purchased Update
entitlement and "RHEL4b2" (RHEL4 WS beta for i386) with Demo update
entitlement.  The two systems were multibooted on the same box.  Then
on Wednesday Feb.16 I fresh installed (not upgrade) released RHEL4 WS
for i386 (Nahant) on top of the old RHEL4b2 system partition, and gave
it the system name "nahant".  Now no matter what I try, I cannot get
up2date working on the newly installed RHEL4 system.

The immediate error when running "up2date --register" is an error
dialog box "Problem sending hardware profile."  This occurs after
deleting the system profile from RHN (temporarily leaving me with 1
registered system and 2 total entitlements), deleting
/etc/sysconfig/rhn/systemid, going through the up2date configuration
panel successfully, entering my RHN account name and password in the
up2date Activate dialog, selecting the radio button for "I have no
subscription code to activate", giving the system name "nahant", and
clicking the Next button.  RHN now sees both systems "taroon" and
"nahant", but nahant has no Base Channel.  In RHN, Selecting nahant >
Alter Channel Subscriptions, choosing "RHEL WS (v.4 for 32-bit x86)",
and clicking Modify Base Channel gives "This assignment would exceed
your allowed subscriptions."



Version-Release number of selected component (if applicable):
up2date-4.4.5-1; Red Hat Network release 3.6.5

How reproducible:
Always

Steps to Reproduce:
1. Delete system profile from RHN, leaving 1 unused Entitlement.
2. Fresh install RHEL4 WS for 32-bit x86.
3. Configure up2date/RHN (from Gnome panel applet), enter RHN account
and password, choose "I have no subscription code to activate", give
system name, click Next.
    

Actual Results:  up2date says "Problem sending hardware profile."  RHN
sees the system with no Base Channel selected, and trying to use RHN
to set the Base Channel says "This assignment would exceed your
allowed subscriptions."

Expected Results:  New system is registered with RHN with Update
[demo] entitlement on base channel RHEL WS (ver.4 for 32-bit x86).

Additional info:

I first did the install of RHEL4 from a self-made DVD, and ran the
"up2date --register" several times, following the RHN FAQ for
restoring entitlement after re-install.  Fearing that my DVD might not
be correct, I re-did the whole install fresh (not upgrade) from the
source CD-ROMs (obtained from EasyISOs), but the problem persists.
Comment 1 Jay Turner 2005-02-18 07:38:28 EST
The "problem sending hardware profile is a known issue (bug 144704).
As for the problems with the channel issues, a demo entitlement can't be used to
manage an official RHEL installation, only things like betas.   You must have a
purchased entitlement for every installation of RHEL you wish to receives
updates for.

*** This bug has been marked as a duplicate of 144704 ***

Note You need to log in before you can comment on or make changes to this bug.