Bug 149014 - xend stops responding after xm destroy
xend stops responding after xm destroy
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-17 17:18 EST by Robin Green
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 03:39:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2005-02-17 17:18:03 EST
Description of problem:
If I destroy a domain with xm destroy, a subsequent xm list command will hang.
Sometimes it is necessary to use xm destroy, because xm shutdown doesn't always
work.

Version-Release number of selected component (if applicable):
xen-2-20050207

How reproducible:
Often

Steps to Reproduce:
1. xm create -c foo
2. CTRL+] to detach from domain foo
3. xm destroy foo
4. xm list
  
Actual results:
xm list hangs

Expected results:
xm list should list domains

Additional info:
All kernels used are the latest kernels (2.6.10-1.1142_FC4) from fedora
development, with my floating-point-workaround patch applied.

Sometimes, service xend restart doesn't make xend work again either, so I have
to reboot the machine.
Comment 1 Rik van Riel 2005-02-23 16:55:12 EST
I have seen this bug too, but it seems to have gone away with
xen-2-20050222, which should be in rawhide in a few days.  Please move
this bug back to ASSIGNED state if it pops up again in the future.

Note You need to log in before you can comment on or make changes to this bug.