Bug 149043 - /usr/lib64/libldap_r.so.2.0.130 does not contain correct dependencies.
/usr/lib64/libldap_r.so.2.0.130 does not contain correct dependencies.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-18 01:34 EST by Dennis
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 20:35:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis 2005-02-18 01:34:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The Fedora Core 3 x86_64 /usr/lib64/libldap_r.so library does 
not have the correct dependencies built in.

Run.

# readelf -a /usr/lib64/libldap_r.so.2.0.130 | grep NEEDED

... Shared library: [liblber-2.2.so.7]
... Shared library: [libresolv.so.2]
... Shared library: [libdl.so.2]
... Shared library: [libc.so.6]

The equivalent command run on Fedora Core 2/Red Hat EL3
x86_64 produce correct dependencies. Likewise Fedora Core
3 i386 produces correct dependencies.

# readelf -a /usr/lib/libldap_r.so.2.0.130 | grep NEEDED

... Shared library: [liblber-2.2.so.7]
... Shared library: [libresolv.so.2]
... Shared library: [libdl.so.2]
... Shared library: [libsasl2.so.2]
... Shared library: [libssl.so.4]
... Shared library: [libcrypto.so.4]
... Shared library: [libc.so.6]

Notice the correct ssl dependencies. Those are missing from
the shipped x86_64 version.

The weird thing is if I build the rpm myself from the Fedora
Core 3 src rpm for x86_64 then the resulting 
libldap_r.so.2.0.130 library does have the correct dependencies.

It appears that maybe the compat-openldap-2.1.30-2.x86_64.rpm 
file was built incorrectly for Fedora Core 3 x86_64. That
same file appears to be correct for Fedora Core 3 i386.

I haven't had time to test Red Hat EL4 x86_64. I would
assume /usr/lib64/libldap_r.so.2.0.130 is broken on that
platform as well.

Version-Release number of selected component (if applicable):
compat-openldap-2.1.30-2

How reproducible:
Always

Steps to Reproduce:
1. # readelf -a /usr/lib64/libldap_r.so.2.0.130 | grep NEEDED


    

Actual Results:  ... Shared library: [liblber-2.2.so.7]
... Shared library: [libresolv.so.2]
... Shared library: [libdl.so.2]
... Shared library: [libc.so.6]

Expected Results:  ... Shared library: [liblber-2.2.so.7]
... Shared library: [libresolv.so.2]
... Shared library: [libdl.so.2]
... Shared library: [libsasl2.so.2]
... Shared library: [libssl.so.4]
... Shared library: [libcrypto.so.4]
... Shared library: [libc.so.6]

Additional info:
Comment 1 Dennis 2005-03-18 01:01:43 EST
It has been a month and it appears that this bug
request has not been looked at.

Just raising it again. This is a very real problem
for us.

Dennis.
Comment 2 Dennis 2005-04-26 23:32:09 EDT
Please close this bug.

I figured it out. Our application was compiled on Red Hat EL3. This build
fails to load up the sub-dependencies of /usr/lib64/libldap_r.so.2.0.130
when run on FC3.

We have now started building our application on Red Hat EL4. This build
does work with respect to loading up the sub-dependencies 
of /usr/lib64/libldap_r.so.2.0.130 on FC3.

I believe the problem relates to our build. This problem was disguised
when run on Red Hat 3 (due to exact library matches build & run). 
However, when run on a installation where the run libraries differ
from the build libraries then we run into trouble.

Apologies for taking up your time. Problem solved.

Thanks.

Dennis.

Note You need to log in before you can comment on or make changes to this bug.