Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 149057 - Some AC'97 modems supported under versions < 2.6.10 by slmodem driver now fail
Some AC'97 modems supported under versions < 2.6.10 by slmodem driver now fail
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://linmodems.technion.ac.il/archi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-18 06:01 EST by Jacques Goldberg
Modified: 2015-01-04 17:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 02:23:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacques Goldberg 2005-02-18 06:01:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040805 Netscape/7.2

Description of problem:
I am  taking care of site http://linmodems.technion.ac.il which
documents and archives drivers for Winmodems to be used under Linux.
The SmartLink analogue modem driver  supports many AC'97 modems in
addition to those made by SmartLink.
Starting with kernel  2.6.10 (actually -1.760) the modem does not work.
The author of the driver and of the above URL proposes a patch in the
kernel serial driver which solves the problem. The patch is in that
Web page.

Many newcomers to Linux and our modem support organization use FC3.
Any newcomer is frightened by having to recompile the kernel.
I suggest to have the patch included in a coming release.

The patch could be very efficiently improved if the list of
problematic devices could be made dynamic, or people will have to
recompile every time such a badly designed modem chipset is discovered
(manufacturer assigning the Modem class  to a soft modem).

The machine used by the author (a friend and graduate from my
university) of the modem driver and of the serial driver patch is in
my office, and indeed the patch solved the problem.

Jacques Goldberg, Prof. of Physics, Technion, Haifa, Israel

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.760-FC3

How reproducible:
Always

Steps to Reproduce:
1. make sure you use a 2.6.10... kernel and have an analogue AC'97 
modem working with the SmartLink driver under an older kernel.
2. download
http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.9b.tar.gz
3. expand, read README, follow the instructions. You will not be able
to start the modem until you patch as in the above URL.
    

Actual Results:  Device grabbed by another driver (actually the serial
driver)

Additional info:
Comment 1 Pierre Francois 2005-03-16 07:57:39 EST
I highly appreciate the effort of Jacques for making the modem driver accessible
for FC3. I found a workaround to get it work, but without patching.

I downloaded the sources of slmodem-2.9.9a from Jacques' website, compiled these
without problems under the kernel 2.6.10-1.770_FC3. I had to modify the
script/slmodemd to include "modprobe slamr" in a similar way as in
script/mandrake/slmodemd because the module slamr wasn't loaded by default. 

And it works...
Comment 2 Pierre Francois 2005-03-16 08:06:11 EST
... However, I am a little puzzled: I need to start slmodemd twice for getting
it working. I can't figure out why.

I use scripts/mandrake/slmodemd as script in the /etc/init.d directory for
starting it as a service under FC3.
Comment 3 Pierre Francois 2005-03-16 08:39:44 EST
Mmmmm... after looking at the scripts, I think it could be related to changes
due to the implementation of udev...
Comment 4 Pierre Francois 2005-03-16 15:54:18 EST
Jacques Goldberg gave me the solution: the script scripts/mandrake/slmodemd of
the sources must be modified:

add

        sleep 10

before the instruction 

        echo -n "Starting SmartLink Modem driver for $SLMODEMD_DEVICE: "

and it works in my case (AC97 modem).
Comment 5 Pierre Francois 2005-03-17 08:50:01 EST
Jacques kindly remarks in a mail he sent me personnaly that my message is
misleading: it gave the solution to something which I raised in a loop of
responses to his original bug report.

In my first message, I said that I had found a workaround: this is not true.

Contrarily to what I initially claimed, I did not find a workaround to the
original bug report, but along the thread, I got a fix for another minor problem
in the script "/etc/init.d/slmodemd" which wrongly made me believe that I was
observing the bug.
Comment 6 Jacques Goldberg 2005-03-18 03:18:49 EST
Thus the problem remains completely unsolved and disturbs more and more people 
every day.

Possible path to a solution:

During the boot process, peripheral PCI devices recognized by the system are 
assigned to specific drivers.

Is there a way to break this association, that is, to return the PCI device to 
being unassigned to any driver?

                    
Comment 7 Dave Jones 2005-07-15 16:30:36 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 8 Dave Jones 2005-12-07 02:23:38 EST
This patch isn't merged upstream, even in latest 2.6.15rc5 tree.
Please submit it to the serial maintainer, Russell King <rmk@arm.linux.org.uk>

Note You need to log in before you can comment on or make changes to this bug.