Bug 1490931 - Doc for Object Gateway API should be more clear
Summary: Doc for Object Gateway API should be more clear
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.3
Hardware: All
OS: All
unspecified
medium
Target Milestone: rc
: 3.*
Assignee: Matt Benjamin (redhat)
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-12 13:57 UTC by Tupper Cole
Modified: 2020-08-05 06:59 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-06 01:06:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tupper Cole 2017-09-12 13:57:12 UTC
Description of problem:Doc on Object Gateway API is unclear regarding user create failures. 


Referencing http://tracker.ceph.com/issues/21371

The community doc states that trying to create an existing user should respond 409:

UserExists

Description: Attempt to create existing user.
Code: 409 Conflict


This is not the case- an additional key and secret are added to the uid.

Also, I can't find a current Red Hat reference for the adminops.

Comment 3 John Wilkins 2018-06-04 18:48:06 UTC
There is an existing entry. The admin ops information is in the downstream developer guide here: https://access.redhat.com/documentation/en-us/red_hat_ceph_storage/3/html/developer_guide/obj-gw-admin-api#create-user

Comment 4 John Wilkins 2018-08-07 16:09:05 UTC
Ken, 

The documentation is correct. The behavior of the API should not allow a user to change the password in this case. It seems to be an issue with the API.

Comment 5 Ken Dreyer (Red Hat) 2018-08-09 21:21:00 UTC
John, would you please clarify "Steps to reproduce", "Actual Results", "Expected Results" for Dev and QE here?


Note You need to log in before you can comment on or make changes to this bug.