Bug 149096 - Sound configuration problem - RHEL4 - es1968 / es1978 - Dell Inspiron 7500
Sound configuration problem - RHEL4 - es1968 / es1978 - Dell Inspiron 7500
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: alsa-lib (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
: 149089 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-18 12:25 EST by Andrei Maslennikov
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 08:11:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrei Maslennikov 2005-02-18 12:25:51 EST
Description of problem:

Hardware:
------------------------
Dell Inspiron 7500 
ESS Technology ES1978 Maestro 2E (rev 10)
RHEL4 with kernel 2.6.9-5.EL/i686

Problem:
---------------------------------------------------
Unable to configure soundcard. The card is correctly recognized,
but produces no sound. It perfectly works with RHEL3 and Windows XP.

# /usr/bin/system-config-soundcard
amixer: Mixer attach default error: No such file or directory
amixer: Mixer attach default error: No such file or directory
aplay: main:508: audio open error: No such file or directory

# cat /proc/interrupts
           CPU0
  0:    9196934          XT-PIC  timer
  1:       7315          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  3:      25775          XT-PIC  3c574_cs
  5:     284236          XT-PIC  ESS Maestro, uhci_hcd
  8:          1          XT-PIC  rtc
  9:         17          XT-PIC  acpi
 11:          2          XT-PIC  yenta, yenta
 12:       3995          XT-PIC  i8042
 14:      31466          XT-PIC  ide0
 15:         17          XT-PIC  ide1
NMI:          0
ERR:          0

# lsmod | grep snd
snd_es1968             34717  0
snd_ac97_codec         63889  1 snd_es1968
snd_pcm_oss            49017  0
snd_mixer_oss          17985  1 snd_pcm_oss
snd_pcm                96841  2 snd_es1968,snd_pcm_oss
snd_timer              29893  1 snd_pcm
snd_page_alloc          9673  2 snd_es1968,snd_pcm
snd_mpu401_uart         8769  1 snd_es1968
snd_rawmidi            26597  1 snd_mpu401_uart
snd_seq_device          8137  1 snd_rawmidi
snd                    54949  9
snd_es1968,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               9889  1 snd
Comment 1 Andrei Maslennikov 2005-02-18 18:17:39 EST
*** Bug 149089 has been marked as a duplicate of this bug. ***
Comment 2 Andrei Maslennikov 2005-02-21 08:11:08 EST
Alsa driver snd_es1968 apparently does not work with this sound card.
Instead, I have compiled OSS/maestro and it worked well. NB: before using
this driver one has to create /dev/dsp, /dev/mixer and others.

I believe this bug may be closed, as Alsa will not support some oldish
cards.. 

Andrei.

Note You need to log in before you can comment on or make changes to this bug.