Bug 149117 - Build of tetex RPMs fails because of missing file "ls-R"
Summary: Build of tetex RPMs fails because of missing file "ls-R"
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-18 21:59 UTC by Joachim Frieben
Modified: 2013-07-02 23:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-28 15:29:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2005-02-18 21:59:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
Building tetex-2.0.2-21.3 on a fully updated FC3 system fails with the
message:

+ mkdir /var/tmp/tetex-root/usr/share/applications
+ desktop-file-install --vendor tetex --delete-original --dir
/var/tmp/tetex-root/usr/share/applications --add-category
X-Red-Hat-Extra --add-category Graphics --add-category Application
xdvi.desktop
/var/tmp/tetex-root/usr/share/applications/tetex-xdvi.desktop:
warning: file contains key "MiniIcon", usage of this key is not
recommended, since it has been deprecated
+ rm -f /var/tmp/tetex-root/var/lib/texmf/ls-R
+ head -n 1 /var/tmp/tetex-root/usr/share/texmf/ls-R
head: cannot open `/var/tmp/tetex-root/usr/share/texmf/ls-R' for
reading: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.73780 (%install)

Version-Release number of selected component (if applicable):
tetex-2.0.2-21.3

How reproducible:
Always

Steps to Reproduce:
1. Execute "rpmbuild --rebuild tetex-2.0.2-21.3.src.rpm"

    

Actual Results:  Watch the above error message appear and "rpmbuild"
abort the packaging of the binary packages.

Additional info:

The various tetex-2.0.2-21.3 binary packages should have built properly.

Comment 1 Joachim Frieben 2005-02-19 14:54:55 UTC
Identical output for the rebuild of "tetex-3.0-1".

Comment 2 Jindrich Novy 2005-02-22 14:17:35 UTC
The log context you presented here looks weird. Could you please send
the whole compile log here as an attachment?

I don't think it's a general problem since I build both the versions
with no problems locally and also our build system and other users had
no complains about it.



Comment 3 Joachim Frieben 2005-02-26 09:20:29 UTC
I have found the reason for the observed behaviour: I've got a local "texmf"
tree, and via the "su" command the TEXMF shell variable got exported to the both
local accounts (install/root) which I had used to try to rebuild the binary
packages.
After correction of this misleading setting, the packages do build as expected.
Unless one does not consider rpmbuild taking into account a local TEXMF shell
variable as undesirable, the issue can be qualified a "NOT A BUG".

Comment 4 Jindrich Novy 2005-02-28 15:29:29 UTC
Ok, thanks for the bugreport anyway.

Jindrich


Note You need to log in before you can comment on or make changes to this bug.