Bug 1491498 - CentOS 7.3 to 7.4 - Transaction check error: file /usr/share/themes/Adwaita/gtk-3.0/gtk.css conflicts between attempted installs of gnome-themes-standard-3.22.2-1.el7.x86_64 and gnome-themes-standard-3.22.2-1.el7.x86_64
Summary: CentOS 7.3 to 7.4 - Transaction check error: file /usr/share/themes/Adwaita...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-themes-standard
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Kalev Lember
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-14 02:36 UTC by nmaludy
Modified: 2021-01-15 07:42 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-15 07:42:07 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description nmaludy 2017-09-14 02:36:04 UTC
Description of problem:

Originally reported here: https://bugs.centos.org/view.php?id=13802


When upgrading from CentOS 7.3 -> 7.4 i receive the following error during the yum transaction:


Total size: 1.1 G
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /usr/share/themes/Adwaita/gtk-3.0/gtk.css conflicts between attempted installs of gnome-themes-standard-3.22.2-1.el7.x86_64 and gnome-themes-standard-3.22.2-1.el7.x86_64


Version-Release number of selected component (if applicable):  gnome-themes-standard-3.14.2.2-2.el7.x86_64


How reproducible: Every time


Steps to Reproduce:
1. yum update
2.
3.

Actual results:


Total size: 1.1 G
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /usr/share/themes/Adwaita/gtk-3.0/gtk.css conflicts between attempted installs of gnome-themes-standard-3.22.2-1.el7.x86_64 and gnome-themes-standard-3.22.2-1.el7.x86_64


Expected results:

Update to run without errors.


Additional info:

Looks like this also occurred in the update from Fedora 24->25 https://bugzilla.redhat.com/show_bug.cgi?id=1387753

I ran the following additional commands to try and debug:

$ rpm -qa gnome-themes-standard\*
gnome-themes-standard-3.14.2.2-2.el7.x86_64
$ yum info gnome-themes-standard-3.14.2.2-2.el7.x86_64
Loaded plugins: fastestmirror, langpacks, priorities, product-id, search-disabled-repos, subscription-manager
Loading mirror speeds from cached hostfile
 * base: mirrors.cmich.edu
 * elrepo: reflector.westga.edu
 * epel: mirror.steadfast.net
 * extras: mirrors.cmich.edu
 * nux-dextop: li.nux.ro
 * updates: mirrors.tripadvisor.com
Installed Packages
Name : gnome-themes-standard
Arch : x86_64
Version : 3.14.2.2
Release : 2.el7
Size : 4.7 M
Repo : installed
From repo : base
Summary : Standard themes for GNOME applications
URL : http://git.gnome.org/browse/gnome-themes-standard
License : LGPLv2+
Description : The gnome-themes-standard package contains the standard theme for the GNOME
            : desktop, which provides default appearance for cursors, desktop background,
            : window borders and GTK+ applications.
$ sudo rpm -V gnome-themes-standard
$ sudo package-cleanup --dupes
Loaded plugins: fastestmirror, langpacks, priorities, product-id

Comment 2 nmaludy 2017-09-14 03:06:02 UTC
For anyone else running into this issue i solved it (using a huge workaround) by doing the following:


# Update the system
$ sudo yum --exclude=gnome-themes-standard --exclude=adwaita-gtk2-theme update

# Reboot
$ sudo reboot

# Download packages from CentOS mirror http://mirror.centos.org/centos/7.4.1708/os/x86_64/Packages/
$ wget http://mirror.centos.org/centos/7.4.1708/os/x86_64/Packages/gnome-themes-standard-3.22.2-1.el7.x86_64.rpm
$ wget http://mirror.centos.org/centos/7.4.1708/os/x86_64/Packages/adwaita-gtk2-theme-3.22.2-1.el7.x86_64.rpm

# Force replace the packages
$ sudo rpm -Uvh --replacefiles --replacepkgs gnome-themes-standard-3.22.2-1.el7.x86_64.rpm adwaita-gtk2-theme-3.22.2-1.el7.x86_64.rpm 

# Yum reinstall so that yum thinks they came from 'base' repo
$ sudo yum reinstall gnome-themes-standard adwaita-gtk2-theme

Comment 4 RHEL Program Management 2021-01-15 07:42:07 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.


Note You need to log in before you can comment on or make changes to this bug.