Bug 149176 - find refuses to run with the -size 'M' unit
Summary: find refuses to run with the -size 'M' unit
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: findutils
Version: 4.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Miloslav Trmač
QA Contact: Mike McLean
URL: man states find -size supports 'M' un...
Whiteboard:
Keywords: Reopened
: 175456 181455 (view as bug list)
Depends On:
Blocks: 187538
TreeView+ depends on / blocked
 
Reported: 2005-02-20 03:59 UTC by ladislav
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-09-27 06:35:08 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0295 low SHIPPED_LIVE findutils bug fix update 2006-04-19 04:00:00 UTC
Red Hat Product Errata RHBA-2006:0679 normal SHIPPED_LIVE findutils bug fix update 2007-05-01 14:09:26 UTC

Description ladislav 2005-02-20 03:59:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922

Description of problem:
find complains about the 'M' (megabyte) -size unit and refuses to run, although the find man page states that find now supports it.

Version-Release number of selected component (if applicable):
findutils-4.1.20-7

How reproducible:
Always

Steps to Reproduce:
1.run 'find -size 10M'
2.
3.
  

Expected Results:  should have worked per man page instead of complaining about undefined/illegal unit specification.

Additional info:

Comment 1 Jay Turner 2005-02-21 13:18:23 UTC
This has already been addressed in a later version of the package (4.1.20-8) so
throwing in Modified.  Just need to get the package build into RHEL4 collection.

Comment 5 Tim Waugh 2005-12-12 18:01:12 UTC
*** Bug 175456 has been marked as a duplicate of this bug. ***

Comment 7 Miloslav Trmač 2006-02-15 01:38:14 UTC
*** Bug 181455 has been marked as a duplicate of this bug. ***

Comment 8 Noman Khanzada 2006-02-15 05:30:30 UTC
in RHEL#4 update #2 the same rpm presence so in which version of rpm that
problem is fixed.

Regards
noman

(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922
> 
> Description of problem:
> find complains about the 'M' (megabyte) -size unit and refuses to run,
although the find man page states that find now supports it.
> 
> Version-Release number of selected component (if applicable):
> findutils-4.1.20-7
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1.run 'find -size 10M'
> 2.
> 3.
>   
> 
> Expected Results:  should have worked per man page instead of complaining
about undefined/illegal unit specification.
> 
> Additional info:

(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922
> 
> Description of problem:
> find complains about the 'M' (megabyte) -size unit and refuses to run,
although the find man page states that find now supports it.
> 
> Version-Release number of selected component (if applicable):
> findutils-4.1.20-7
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1.run 'find -size 10M'
> 2.
> 3.
>   
> 
> Expected Results:  should have worked per man page instead of complaining
about undefined/illegal unit specification.
> 
> Additional info:



Comment 14 Red Hat Bugzilla 2006-04-19 19:05:33 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0295.html


Comment 15 Johnny Hughes 2006-08-14 17:10:01 UTC
The latest find in the newly release RHEL4u4 (the one in at the above link) does
not work with -size 1M.

Still has findutils-4.1.20-7 ... this is not fixed.

Comment 16 Johnny Hughes 2006-08-14 17:17:26 UTC
the changelog says it is no longer on the man page ... however it is still there

 -size n[cwbkMG]



Comment 17 Miloslav Trmač 2006-09-08 21:32:26 UTC
Johnny, thanks for pointing this out.

Comment 22 Red Hat Bugzilla 2006-09-27 06:35:08 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0679.html



Note You need to log in before you can comment on or make changes to this bug.