Bug 149178 - Installer crashes right at the end with rpmio_internal.h assertion failure
Installer crashes right at the end with rpmio_internal.h assertion failure
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-20 01:27 EST by Gabriel Schulhof
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 14:46:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel Schulhof 2005-02-20 01:27:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.6 (KHTML, like Gecko) Safari/125.12

Description of problem:
Very frustating: When the installer is about to finish, this happens:
python: ./rpmio_internal.h:522: c2f: Assertion 'fd && fd->magic == 0x04463138' failed.

The installer brings the computer to a halt:
"It is now safe to reboot your computer" - or something to that effect

Version-Release number of selected component (if applicable):
anaconda-10.2.0.19-1.ppc

How reproducible:
Always

Steps to Reproduce:
1. Install on a ppc from download.fedora.redhat.com/pub/fedora/linux/core/development/ppc

Actual Results:  Installer dies right at the end, which is really frustrating.

Expected Results:  Installer does not die right at the end, which is a big relief.

Additional info:
Comment 1 Jeremy Katz 2005-02-20 21:16:09 EST
This is _probably_ caused by a bad tree.
Comment 2 Paul Nasrat 2005-02-20 23:43:33 EST
When did you mirror the tree - so I can try and replicate here. Can you give me
the buildstamp/discinfo so I can ensure I'm testing against the correct tree.

I've done a ppc install based off a tree built between 19 and 20 February, which
installs fine.
 
From a full tree:  cat .discinfo

From boot.iso:

mount -o loop boot.iso /mnt
zcat /mnt/ppc/mac/ramdisk.image.gz > /tmp/ramdisk.image
umount /mnt
cd /tmp; cpio -ivd .buildstamp < ramdisk.image
cat .buildstamp


Comment 3 Gabriel Schulhof 2005-02-21 17:15:13 EST
Unfortunately, I didn't take a snapshot of the tree. I installed
directly from
download.fedora.redhat.com/pub/fedora/linux/core/development/ppc over
http.

Thus, if the tree has changed since then, I can not replicate the problem.

The .discinfo at this writing (2005-02-21 15:14 MST) reads:
1108985286.752955
Fedora Core 4
ppc
1,2,3,4
Fedora/base
Fedora/RPMS
Fedora/pixmaps

FWIW
Comment 4 Gabriel Schulhof 2005-02-22 01:44:34 EST
This same error has just happened during package download when I ran

yum -y update.

yum is yum-2.1.13-1.ppc
Comment 5 Paul Nasrat 2005-02-23 07:39:53 EST
Is this reproducible with yum?  Can you narrow down the package it is failing at
(try yum -d 5 -y update.  Can you check using rpm -K the contents of
/var/cache/yum/development/packages

rpm -K /var/cache/yum/development/packages/*rpm | grep NOT
Comment 6 Jeremy Katz 2005-04-19 14:46:34 EDT
Closing due to inactivity.  If this issue still occurs with current releases,
please reopen and set the release in which you've encountered the problem.

Note You need to log in before you can comment on or make changes to this bug.