Bug 149184 - RHEL4 install from local drive boots to grub> prompt
RHEL4 install from local drive boots to grub> prompt
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: booty (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-20 07:53 EST by Robert G. 'Doc' Savage
Modified: 2012-06-20 09:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:20:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert G. 'Doc' Savage 2005-02-20 07:53:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041220 Fedora/1.7.5-2

Description of problem:
First reboot following package installation from local drive stops at the grub> prompt.

Version-Release number of selected component (if applicable):
February 14 distribution iso images

How reproducible:
Always

Steps to Reproduce:
1. Boot from CD 1
2. boot: linux askmethod
3. manually select i2o_block driver
4. set source path to /dev/i2o/hdb with path distributions/RHEL4/Release/ES
5. delete all partitions on /dev/i2o/hda and automatically partition w/DiskDruid
6. select Everything
7. when complete, remove CD and click on [Reboot]
  

Actual Results:      GNU GRUB  version 0.95  (633K lower / 3143616K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename.]

grub> _

Expected Results:  Should have proceeded to stage 2 menu.

Additional info:

Workaround: "boot: linux rescue" from CD#1, manually install i2o_block driver (again), chroot /mnt/sysimage, and run:
# grub-install /dev/i2o/hda
System can then reboot into Firstboot.

All RHEL4 iso md5sums checked OK.

Contents of /boot/grub/grub.conf:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/iso/hda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title RHEL4 ES [Distribution] (2.6.9-5.ELsmp)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-5.ELsmp ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.9-5.ELsmp.img
title RHEL4 ES [Distribution]-up (2.6.9-5.EL)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-5.EL ro root=/dev/VolGroup00/LogVol00 rgb quiet
        initrd /initrd-2.6.9-5.EL.img

Output from fdisk -l /dev/i2o/hda:
Disk /dev/i2o/hda: 18.1 GB, 18113800192 bytes
255 heads, 63 sectors/track, 2202 cyllinders
Units = cylinders of 16065 * 512 = 8225280 bytes
       Device Boot      Start         End      Blocks   Id  System
/dev/iso/hda1   *           1          13      104391   83  Linux
/dev/iso/hda2              14        2202    17583142+  8e  Linux LVM

Extract from /root/anaconda.log:
...
* moving (1) to step writeconfig
* Writing main configuration
* moving (1) to step firstboot
* moving (1) to step instbootloader
* GRUB command root (hd0,0)
install /grub/stage1 d (hd0) /grub/stage2 p (hd0,0)/grub/grub.conf
...
Comment 1 Jeremy Katz 2005-02-20 21:14:20 EST
What did /boot/grub/grub.conf contain?  Also, any error messages on tty5?
Comment 2 Robert G. 'Doc' Savage 2005-02-21 13:32:33 EST
Jeremy,

The contents of /boot/grub/grub.conf were in my bug comments. I didn't check
tty5 because I wasn't anticipating any errors, but I also included what should
be the relevant lines in anaconda.log. Everything _looks_ nominal.

If you like I can attach the whole anaconda.log file.

--Doc

Comment 3 Scott Becker 2005-02-22 13:39:46 EST
I had a very simular problem. On install I had to select i2o_block and then the
install and reboots went fine. Friday I installed all the updates including the
updated kernel, and on reboot, it got to 'GRUB _' and it hung. Numlock would not
respond. Using linux rescue looked in the /boot and /boot/grub dirs and
everything looked fine. Then I ran 'grub_install /dev/i2o/hda' and now it boots
properly.

In the grub manual under 'Invoking the Grub' shell it says: Note that the grub
shell is an emulator; it doesn't run under the native environment, so it
sometimes does something wrong. I wonder if this isn't an issue like this. I
also wonder if it isn't a combination of i2o_block and LVM.
Comment 4 Bruce 2009-07-01 11:42:54 EDT
I have 2 identical machines, both having dual boot into linux fedora 10 or XP. I ran the upgrade to Fedora 10 on the first machine and everything went fine. When I did it on machine 2 it downloaded everything and then when it rebooted it hung at GRUB. I am a newbie at this and do not have a Fedora 11 DVD. But I do have a Fedora 10 DVD Can someone please help me out with this?
Thank You Kindly
Comment 5 Bruce 2009-07-01 20:44:48 EDT
That should read I ran the downloaded upgrade to Fedora 11 on the first machine
and followed all the instructions:
yum update rpm
Then we install the latest updates: yum -y update
Next we clean the yum cache: yum clean all
If you notice that a new kernel got installed during yum -y update, you should reboot the system now:reboot
Now we come to the upgrade process. We can do this with preupgrade (preupgrade will also take care of your RPMFusion packages).
Install preupgrade...yum install preupgrade
... and call it like this:preupgrade

Everything went fine and after it rebooted Fedora 11 ran just great
I did exactly the same on the second machine and it hung at GRUB after it rebooted

I am a newbie at this and do not have a Fedora 11 DVD. But I
do have a Fedora 10 DVD Can someone please help me out with this? The instructions above are a bit dicey foe me :-((
Thank You Kindly,
Bruce
Comment 6 Jiri Pallich 2012-06-20 09:20:53 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.