Bug 149196 - Error in up2date.py: runTransaction takes 4 arguments, not 2
Summary: Error in up2date.py: runTransaction takes 4 arguments, not 2
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-20 23:29 UTC by Michael Pearson
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 12:43:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Pearson 2005-02-20 23:29:13 UTC
See linked bug #138437. Adding this bug to denote bug's presence in a released
enterprise-level product.

Comment 1 Michael Pearson 2005-02-21 06:56:28 UTC
Rebooted after errata upgrade, now cannot reproduce error.

Comment 2 Jay Turner 2005-02-21 12:43:59 UTC
This problem should have been resolved with the 4.3.51 release quite some time
ago (and well before RHEL4 GA'd.)  Please reopen this bug if you're able to
reproduce.

Comment 3 Need Real Name 2005-09-07 21:07:41 UTC
I seem to be reproducing this bug just fine...  My three systems with RHEL WS
4U1, using a satellite server that can't schedule package updates without the
following type of error:

[root@db08 ~]# rhn_check -v
packages.remove ([['aspell-de', '0.50', '9', '50'], ['aspell-fr', '0.50', '7',
'50'], ['gaim', '1.3.1', '0.el4.3', '1'], ['kde-i18n-Chinese', '3.3.1', '2.1',
'1'], ['kde-i18n-Chinese-Big5', '3.3.1', '2.1', '1'], ['kde-i18n-French',
'3.3.1', '2.1', '1'], ['kde-i18n-German', '3.3.1', '2.1', '1'],
['kde-i18n-Japanese', '3.3.1', '2.1', '1'], ['kde-i18n-Spanish', '3.3.1', '2.1',
'1']],)
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 174, in run_action
    (status, message, data) = do_call(method, params)
  File "/usr/sbin/rhn_check", line 91, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 83, in remove
    up2date.removePackages(pkgList, rpmCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1009, in removePackages
    runTransaction(ts,rpmCallback)
TypeError: runTransaction() takes at least 4 arguments (2 given)
[root@db08 ~]#

They have up2date versions of everything that is installed, and specifically:
[root@db08 up2date_client]# rpm -q up2date
up2date-4.4.5.6-2
[root@db08 up2date_client]# rpm -q python
python-2.3.4-14.1




Note You need to log in before you can comment on or make changes to this bug.