Bug 149252 - popt needs to be a independent package
popt needs to be a independent package
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-21 12:48 EST by Nathan G. Grennan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 12:58:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2005-02-21 12:48:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050109 Galeon/1.3.19

Description of problem:
popt can't have a sub devel package while it is a sub package of rpm. This is a limitation of rpm. The inability to have a sub package of a sub package. I realize popt was originally development for rpm, but is now used by many other packages.

The comment below was found in rpm.spec 4.3.2-21, and I see why.

# XXX These may end up in popt-devel but it hardly seems worth the effort.

Version-Release number of selected component (if applicable):
4.4.1-2

How reproducible:
Always

Steps to Reproduce:
1. grep popt rpm.spec
  

Actual Results:  Requires: popt = 1.9.1
%package -n popt
%description -n popt
%package -n popt-devel
Summary: Files needed for development of  popt.
Requires: popt = %{version}-%{release}
%description -n popt-devel
The popt-devel package contains header files needed for popt
%post -n popt -p /sbin/ldconfig
%postun -n popt -p /sbin/ldconfig


Expected Results:  Requires: popt = 1.9.1

Additional info:

This relates to my other bug.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=149141
Comment 1 Jeff Johnson 2005-02-21 12:58:25 EST
No. popt is maintained with rpm because popt is far far more
extensively used than any other package.

Drop it already, you're annoying.
Comment 2 Nathan G. Grennan 2005-02-21 13:04:08 EST
So is your refusal to fix a bug.

Note You need to log in before you can comment on or make changes to this bug.