Bug 149290 - invalid free when CC is bogus.
invalid free when CC is bogus.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-21 18:56 EST by Dave Jones
Modified: 2016-11-24 07:27 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.3.4-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-10 04:16:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2005-02-21 18:56:16 EST
(18:35:14:davej@hanger18:linux-2.6.10)$ make -j1 bzImage CC=gcc-4.0
*** glibc detected *** make: free(): invalid pointer: 0x000000000053633e ***
Killed
Comment 1 Jakub Jelinek 2005-02-22 15:27:37 EST
Can't reproduce this.  Was this on an freshly unpacked tree or something else?
I was trying rpmbuild -bp --target i686'ed kernel tree from latest rawhide.
Comment 2 Jakub Jelinek 2005-02-24 13:31:47 EST
This is http://sources.redhat.com/ml/libc-hacker/2005-02/msg00059.html
Recently introduced, and will be fixed once new rawhide glibc is built.
Comment 3 Jakub Jelinek 2005-03-10 04:16:09 EST
Should be fixed in glibc-2.3.4-11 and above.

Note You need to log in before you can comment on or make changes to this bug.