Bug 1493044 - Failed to remove old efi boot entry
Summary: Failed to remove old efi boot entry
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 8.1
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-19 08:54 UTC by cshao
Modified: 2020-11-03 20:36 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-02 14:05:21 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
efi (67.92 KB, image/png)
2017-09-19 08:54 UTC, cshao
no flags Details
all log info (9.48 MB, application/x-gzip)
2017-09-19 08:55 UTC, cshao
no flags Details

Description cshao 2017-09-19 08:54:14 UTC
Created attachment 1327823 [details]
efi

Description of problem:
An error info pop-up during anaconda GUI installation.

ERR anaconda: bootloader.write failed: failed to remove old efi boot entry.  This is most likely a kernel bug.


Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.1-20170914.1
imgbased-0.9.47-0.1.el7ev.noarch


How reproducible:
60%

Steps to Reproduce:
1. Install redhat-virtualization-host-4.1-20170512.0(4.1.2) on UEFI machine.
2. Reboot, install redhat-virtualization-host-4.1-20170914.1
3. Choose auto partitioning on Anaconda GUI, and finish other mandatory steps. 
4. Focus on the installation process.
5. Ignore the error, reboot.
6. Login RHVH.

Actual results:
1. An error info pop-up during anaconda GUI installation.
2. After step 6, login RHVH can successful.

Expected results:
No error pop-up during anaconda GUI installation.

Additional info:

Comment 1 cshao 2017-09-19 08:55:10 UTC
Created attachment 1327825 [details]
all log info

Comment 5 cshao 2019-07-11 07:49:55 UTC
Test version:
RHEL-8.1.0-20190701.0-x86_64-dvd1.iso

Test result:
Met error during boot RHEL 8 on EFI machine:
error: ../../grub-core/loader/i386/efi/linux.c:208:/images/pxeboot/vmlinuxz has invalid signature.
error: ../../grub-core/loader/i386/efi/linux.c:93:you need to load the kernel first.

Press any key to continue ...

Comment 6 Jan Stodola 2020-09-25 19:50:32 UTC
Hello cshao,
are you still able to reproduce it on RHEL-8.3? If yes, can you please upload the installation logs?
Thank you

Comment 7 cshao 2020-09-27 08:39:18 UTC
(In reply to Jan Stodola from comment #6)
> Hello cshao,
> are you still able to reproduce it on RHEL-8.3? If yes, can you please
> upload the installation logs?
> Thank you

Test version:
RHEL-8.3.0-20200909.1-x86_64-dvd1.iso

Test steps:
Install RHEL-8.3.0-20200909.1-x86_64-dvd1.iso on UEFI machine.

Test result:
Failed to boot RHEL 8.3 on UEFI machine.

error: ../../grub-core/loader/i386/efi/linux.c:215:/images/pxeboot/vmlinuz has invalid signature.
error: ../../grub-core/loader/i386/efi/linux.c:94:you need to load the kernel first.

Press any key to continue...

I think this is due to RHEL 83 kernel isn't released yet.


==================================
But No such issue with RHEL-8.2.0-20200404.0-x86_64-dvd1.iso, so I think this bug is fixed.

Comment 10 Jan Stodola 2020-11-02 14:05:21 UTC
Closing based on comment 7.
Thank you for retesting, cshao.


Note You need to log in before you can comment on or make changes to this bug.