Bug 149319 - top crashes when terminal window is resized
Summary: top crashes when terminal window is resized
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: procps   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 150580 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-22 13:03 UTC by Per Steinar Iversen
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-17 12:54:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Per Steinar Iversen 2005-02-22 13:03:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20050117 Fedora/1.7.5-3

Description of problem:
On x86_64: Start top in xterm windows. Resize the window continously,
eventually top dies with the message:

*** glibc detected *** realloc(): invalid next size:
0x000000000062b310 ***

The long hex number in the error message seems to be different each time.

If top is started this way there is more info:

MALLOC_CHECK_=1 top

*** glibc detected *** realloc(): invalid pointer: 0x000000000060f520 ***
*** glibc detected *** malloc(): memory corruption: 0x0000000000610970
*** 

Version-Release number of selected component (if applicable):
procps-3.2.3-5.1.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start top in terminal windows
2. Resize the window a number of times
3. Eventually top dies
    

Actual Results:  top dies

Expected Results:  top should continue to run

Additional info:

This happens on both i686 and x86_64

Comment 1 Karel Zak 2005-03-17 10:59:32 UTC
*** Bug 149616 has been marked as a duplicate of this bug. ***

Comment 2 Karel Zak 2005-03-17 11:00:43 UTC
*** Bug 150580 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.