This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 149327 - focus doesn't follow mouse when used tabbed terminals
focus doesn't follow mouse when used tabbed terminals
Status: CLOSED DUPLICATE of bug 153221
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-22 09:56 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 12:20:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-02-22 09:56:28 EST
Description of problem:
I have focus-follows-mouse in my windows preferences.
When gnome-terminal is untabbed, then this works.
When gnome terminal is tabbed then this doesn't work.

Version-Release number of selected component (if applicable):
gnome-terminal-2.9.2-1

How reproducible:
100%

Steps to Reproduce:
1.Open 2 gnome-terminals
2.Open second tab in one of the terminals.
3.Move mouse from untabbed terminal and select either tab of the
tabbed terminal, but without traversing over the terminal area of the
tabbed terminal.
  
Actual results:
The tabbed gnome-terminal no longers accepts focus as mouse is moved
around the screen.

Expected results:
focus-follows-mouse


Additional info:
Comment 1 John Ellson 2005-03-31 17:48:20 EST
Perhaps its not a focus-follows-mouse problem.

I can get a tabbed terminal window to loose ability to focus from
focus-follows-mouse by selecting the tab with a click-drag-release within the
tab area rather than just a click-and-release without motion.   You can tell
when the problem is occurring because a dotted box appears around the tab.

It seems to be fairly sensitive to timing.  Basically the mouse has to be in
moton as you click.  Click followed by a delayed drag doesn't do it.

Normal focus behavior is restored by clicking in the terminal window, this also
causes the dotted box to disapear.

Perhaps there is an additional binding to the tab widget that needs to be
disabled?   Is the tab grabbing entry focus?

Comment 2 John Ellson 2005-04-01 21:29:48 EST
Even easier.   Double-click on the tab causes the dotted box to appear and
focus-follow-mouse to fail.
Comment 3 Olav Vitters 2005-04-03 10:55:27 EDT
See http://bugzilla.gnome.org/show_bug.cgi?id=117240

Dragging selects the tabbar. The tabbar needs to be selectable because of
accessability reasons. Whether it should be focussed when dragging is a gtk
question.
Comment 4 John Ellson 2005-04-03 12:15:28 EDT
I think you're refering to double-click selection, but the tab is also selected
by click-drag and the focus isn't relinquished as the mouse moves away and back
again.

Reported against Gtk:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=153221
Comment 5 Ray Strode [halfline] 2005-08-31 12:20:19 EDT

*** This bug has been marked as a duplicate of 153221 ***

Note You need to log in before you can comment on or make changes to this bug.