Bug 1493380 - SELinux is preventing cups-pdf from access to ${DESKTOP}
Summary: SELinux is preventing cups-pdf from access to ${DESKTOP}
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 26
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-20 05:29 UTC by Luigi Cantoni
Modified: 2018-05-29 12:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-29 12:47:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Luigi Cantoni 2017-09-20 05:29:44 UTC
Description of problem:
Cups-pdf get prevent from creating/overwriting a pdf fime in the ${DESKTOP} directory

Version-Release number of selected component (if applicable):
cups-pdf.x86_64                      2.6.1-12.fc26  

How reproducible:
every time

Steps to Reproduce:
1. create a pdf through the print manager
2.
3.

Actual results:
SELinux report errors errors like
SELinux is preventing cups-pdf from open access on the file /app/us/XXX/.config/user-dirs.dirs.
SELinux is preventing gs from add_name access on the directory XXX.pdf.

Expected results:
Should be allowed access the files etc.
Other errors are reported also

Additional info:
I have tried setting the .conf file to other directories like ${HOME} and it still fails.
I have tried doing what the suggested solutions to grant the permissions but that does not appear to help.
# ausearch -c 'gs' --raw | audit2allow -M my-gs
# semodule -X 300 -i my-gs.pp

This appears to be my only SELinux issue otherwise my system works fine with the setting
SELINUX=enforcing
Setting it to permissive obviously allows me to continue
SELINUX=permissive

This has been happening for a while (I think since 26) and I hopes it would get sorted with some update.

Comment 1 Fedora End Of Life 2018-05-03 08:30:52 UTC
This message is a reminder that Fedora 26 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 26. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '26'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 26 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 2 Fedora End Of Life 2018-05-29 12:47:09 UTC
Fedora 26 changed to end-of-life (EOL) status on 2018-05-29. Fedora 26
is no longer maintained, which means that it will not receive any
further security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.