Bug 1493891 - TypeError: 'NoneType' object is not subscriptable
Summary: TypeError: 'NoneType' object is not subscriptable
Keywords:
Status: CLOSED DUPLICATE of bug 1451628
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3f2c50fefdadb503e799c1d8fd6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-21 06:42 UTC by lnie
Modified: 2017-09-21 10:10 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-21 10:10:48 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (722.96 KB, text/plain)
2017-09-21 06:44 UTC, lnie
no flags Details
File: anaconda.log (48.12 KB, text/plain)
2017-09-21 06:44 UTC, lnie
no flags Details
File: environ (509 bytes, text/plain)
2017-09-21 06:44 UTC, lnie
no flags Details
File: journalctl (234.47 KB, text/plain)
2017-09-21 06:44 UTC, lnie
no flags Details
File: lsblk_output (1.75 KB, text/plain)
2017-09-21 06:44 UTC, lnie
no flags Details
File: nmcli_dev_list (1.21 KB, text/plain)
2017-09-21 06:44 UTC, lnie
no flags Details
File: os_info (596 bytes, text/plain)
2017-09-21 06:44 UTC, lnie
no flags Details
File: program.log (42.91 KB, text/plain)
2017-09-21 06:45 UTC, lnie
no flags Details
File: storage.log (314.48 KB, text/plain)
2017-09-21 06:45 UTC, lnie
no flags Details
File: ifcfg.log (2.29 KB, text/plain)
2017-09-21 06:45 UTC, lnie
no flags Details

Description lnie 2017-09-21 06:42:33 UTC
Version-Release number of selected component:
anaconda-core-27.20.1-3.fc27.x86_64

The following was filed automatically by anaconda:
anaconda 27.20.1-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.6/site-packages/blivet/udev.py", line 474, in device_get_md_uuid
    return util.canonicalize_UUID(info["MD_UUID"])
  File "/usr/lib/python3.6/site-packages/blivet/devices/md.py", line 418, in status
    uuid = udev.device_get_md_uuid(info)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 490, in destroy
    log_method_call(self, self.name, status=self.status)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/deviceaction.py", line 374, in execute
    self.device.destroy()
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 325, in process
    action.execute(callbacks)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 48, in wrapped_func
    return func(obj, *args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 163, in do_it
    self.devicetree.actions.process(callbacks=callbacks, devices=self.devices)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/osinstall.py", line 1112, in turn_on_filesystems
    storage.do_it(callbacks)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 438, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 472, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation.py", line 365, in doInstall
    installation_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threading.py", line 252, in run
    threading.Thread.run(self)
TypeError: 'NoneType' object is not subscriptable

Additional info:
addons:         com_redhat_kdump
blivet-gui-utils.log: 
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img root=live:CDLABEL=Fedora-WS-Live-27-20170920-n-0 rd.live.image rd.live.check quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.13.0-0.rc7.git0.1.fc27.x86_64
other involved packages: python3-blivet-2.1.10-1.fc27.noarch, python3-libs-3.6.2-13.fc27.x86_64
product:        Fedora
release:        Fedora release 27 (Twenty Seven)
type:           anaconda
version:        27

Comment 1 lnie 2017-09-21 06:44:05 UTC
Created attachment 1328788 [details]
File: anaconda-tb

Comment 2 lnie 2017-09-21 06:44:12 UTC
Created attachment 1328789 [details]
File: anaconda.log

Comment 3 lnie 2017-09-21 06:44:14 UTC
Created attachment 1328790 [details]
File: environ

Comment 4 lnie 2017-09-21 06:44:52 UTC
Created attachment 1328791 [details]
File: journalctl

Comment 5 lnie 2017-09-21 06:44:54 UTC
Created attachment 1328792 [details]
File: lsblk_output

Comment 6 lnie 2017-09-21 06:44:56 UTC
Created attachment 1328793 [details]
File: nmcli_dev_list

Comment 7 lnie 2017-09-21 06:44:58 UTC
Created attachment 1328794 [details]
File: os_info

Comment 8 lnie 2017-09-21 06:45:05 UTC
Created attachment 1328795 [details]
File: program.log

Comment 9 lnie 2017-09-21 06:45:53 UTC
Created attachment 1328797 [details]
File: storage.log

Comment 10 lnie 2017-09-21 06:45:55 UTC
Created attachment 1328798 [details]
File: ifcfg.log

Comment 11 Samantha N. Bueno 2017-09-21 10:10:48 UTC

*** This bug has been marked as a duplicate of bug 1451628 ***


Note You need to log in before you can comment on or make changes to this bug.