Bug 149458 - the device '/class/net/tun0' properly (no device symlink)
the device '/class/net/tun0' properly (no device symlink)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 06:06 EST by Julien Dumont
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-23 06:31:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Julien Dumont 2005-02-23 06:06:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
either wait_for_sysfs (udev 039)  needs an update to handle the device
'/class/net/tun0' properly (no device syml ink) or the sysfs-support
of your device's driver needs to be fixed, please repo rt to
<linux-hotplug-devel@lists.sourceforge.net>


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667  rpm-4.3.2-21 udev-039-8.FC3

How reproducible:
Always

Steps to Reproduce:
1. restart openvpn
2.
3.
    

Actual Results:  in /var/log/message

wait_for_sysfs[1362]: either wait_for_sysfs (udev 039)  needs an
update to handle the device '/class/net/tun0' properly (no device syml
ink) or the sysfs-support of your device's driver needs to be fixed,
please repo rt to <linux-hotplug-devel@lists.sourceforge.net>



Expected Results:  noting in /var/log/message

Additional info:

dmesg : 
-------
Universal TUN/TAP device driver 1.5 (C)1999-2002 Maxim Krasnyansky
divert: not allocating divert_blk for non-ethernet device tun0
divert: no divert_blk to free, tun0 not ethernet

/var/log/message :
------------------
wait_for_sysfs[1362]: either wait_for_sysfs (udev 039)  needs an
update to handle the device '/class/net/tun0' properly (no device syml
ink) or the sysfs-support of your device's driver needs to be fixed,
please repo rt to <linux-hotplug-devel@lists.sourceforge.net>
Comment 1 Harald Hoyer 2005-02-23 06:31:25 EST
please update your udev!

Note You need to log in before you can comment on or make changes to this bug.