Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1495064 - [RFE] Creating custom report by node within project for OpenShift provider
Summary: [RFE] Creating custom report by node within project for OpenShift provider
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: GA
: cfme-future
Assignee: Gregg Tanzillo
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-25 06:05 UTC by tachoi
Modified: 2019-01-25 20:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-25 20:32:38 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description tachoi 2017-09-25 06:05:42 UTC
Description of problem:
Tried to create custom report by node within project for Openshift provider
There are 2 options to create custom report relate to this
- Cloud Intel => Reports => Reports => Create New Report
- Type Name and Title 
=> Performance - Container Nodes
=> Performance - ContainerProjects

What we are looking for is to get "Node performance report" under "Container Project" hierarchically.

We couldn't find to join these 2 reports with Project base

Version-Release number of selected component (if applicable):
CFME 5.8.1.5 
Openshift v3.6.173.0.5
kubernetes v1.6.1+5115d708d7

How reproducible:
Enable metrics for Openshift provider
Collect metrics for Openshift provider
Having multiple nodes

Steps to Reproduce:
1. Cloud Intel => Reports => Reports => Create New Report 
2. 
3.

Actual results:

Expected results:

Additional info:
There are many Node related fields(Node: CPU - Aggregated Usage Rate ...) from "Performance - ContainerProjects" base report
But the report output is not showing individual Node base info like "Performance - Container Nodes"

Comment 4 tachoi 2017-09-27 22:53:11 UTC
Hi Team

Can someone have a look this issue?

- 1st question : Creating custom report by node within project for OpenShift provider 
- 2nd question : Node related fields(Node: CPU - Aggregated Usage Rate ...) from "Performance - ContainerProjects" base report
But the report output is not showing individual Node base info like "Performance - Container Nodes"

Thanks 
Taeho

Comment 5 Gregg Tanzillo 2018-05-11 16:21:14 UTC
Hi Taeho,

There are a couple of issues preventing creation of the reports your requesting -

1. Report based on ContainerProject performance
Container  projects have many nodes. That is, a project can be running on more than one node. Therefore there is not way to report the portion of usage of a specific project for each node running it. The usage metrics apply to all pods running in the project on all nodes

2. Report based on ContainerNode performance
Here, there is not relationship back to projects. But, if there was, it would have the same issue because there is not way to separate out the amount of usage of a project for each specific node running it.


Note You need to log in before you can comment on or make changes to this bug.