Bug 149512 - Wrong icon for Emacs button in window list
Wrong icon for Emacs button in window list
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 13:14 EST by August
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 04:51:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description August 2005-02-23 13:14:50 EST
Description of problem:
During startup of GNU Emacs on Fedora Core 3 the initial icon in the
window list is the gnu icon, but it's then replaced by the default
"empty sheet" icon when Emacs has started. This replacement shouldn't
take place.

Version-Release number of selected component (if applicable):
GNU Emacs 21.3.1 (i386-redhat-linux-gnu, X toolkit, Xaw3d scroll bars)
of 2005-02-04 on bugs.build.redhat.com

How reproducible:
Allways.

Steps to Reproduce:
1. Launch GNU Emacs.
2. Look at the button in the window list that pops up.
  
Actual results:
The icon for the button in the window list is initially a gnu, but is
quickly replaced by a default "empty sheet" icon.

Expected results:
It should keep the gnu icon.

Additional info:
Comment 1 Jens Petersen 2005-04-08 02:55:56 EDT
This is a longstanding bug I'm afraid.
Any clues on how to fix this would appreciated...
Comment 2 Jens Petersen 2005-05-17 22:58:45 EDT
Interestingly the right icon is shown with KDE.
Comment 3 Peter Oliver 2005-06-16 20:24:21 EDT
Here's a possibly related problem in Fedora Core 4.  The file /usr/bin/emacs is
actually a wrapper script that runs the emacs-x binary.  If your app-defaults
are set up to expect the binary name to be "emacs", they fail to take effect,
e.g., "emacs*Background: DarkSlateGray".  However, "Emacs*Background:
DarkSlateGray" works.

Running "exec -a emacs emacs-x" causes "emacs" app-defaults to take effect and
the Gnu icon to appear as expected.
Comment 4 Jens Petersen 2005-06-16 22:28:48 EDT
Well the wrapper is new in FC4 actually, ie it wasn't in FC3
so I don't think it is directly related to the problem.

I take your point about the Xresource name vs application name
issue though, Peter: I'll add "-a emacs" to the wrapper script
in the next devel build.

However even with "-a emacs" I still don't see the emacs icon under gnome.
Comment 5 Peter Oliver 2005-06-19 14:28:57 EDT
It turns out that I see an icon because I have "Emacs*bitmapIcon: on" in my
.Xresources.

I notice that there's no app-defaults file for Emacs.  I'm pretty sure that this
wasn't always the case.
Comment 6 Dave Malcolm 2005-06-24 15:13:55 EDT
Should emacs be setting the _NET_WM_ICON property directly?

See e.g. the implementation of gdk_window_set_icon_list here:
http://cvs.gnome.org/viewcvs/gtk%2B/gdk/x11/gdkwindow-x11.c?view=markup
Comment 7 Wei-Lun Chao 2005-07-07 05:38:15 EDT
it looks like, with option -i, that emacs will only set iconPixmap but not iconMask.
Comment 8 Jens Petersen 2005-09-29 08:06:09 EDT
> Should emacs be setting the _NET_WM_ICON property directly?

Good question.  Maybe.  On the other hand XEmacs doesn't
and its icon displays ok.
Comment 10 Jens Petersen 2005-10-03 04:51:40 EDT
Apparently this is fixed in current cvs emacs.
Comment 11 Jens Petersen 2005-10-03 06:19:15 EDT
Confirmed fixed in current cvs with "emacs -i".

Note You need to log in before you can comment on or make changes to this bug.