Bug 149515 - update fails if last file in /usr/share/icons/* is not a dir
update fails if last file in /usr/share/icons/* is not a dir
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-icon-theme (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 13:55 EST by Alexandre Oliva
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-04 01:00:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-02-23 13:55:14 EST
If the last entry in the expansion of /usr/share/icons/* in the %post
of gnome-icon-theme and redhat-artwork, the install will fail because
gtk-update-icon-cache will exit with a non-zero status when not given
a directory.  On my case, the last entry is xpdf.png, on an
`everything' install of rawhide.  I had more than one version of these
packages installed becuase they'd fail to update correctly.

I suggest replacing /usr/share/icons/* with /usr/share/icons/*/, if
gtk-update-icon-cache accepts that, or running test ! -d $dir ||
gtk-update-icon-cache.

Version-Release number of selected component (if applicable):
gnome-icon-theme-2.9.91-1 redhat-artwork-0.120-5

How reproducible:
Always
Comment 1 Matthias Clasen 2007-04-04 01:00:26 EDT
We are doing the -d $dir test nowadays.

Note You need to log in before you can comment on or make changes to this bug.