Bug 149527 - 6 * missing return statements
6 * missing return statements
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: d4x (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 14:57 EST by David Binderman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-03 07:49:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2005-02-23 14:57:31 EST
Description of problem:

I just tried to compile package d4x-2.5.0-2 from 
Redhat Fedora Extras development tree.

The compiler said

list.cc(1220): warning #1011: missing return statement at end of
non-void function "d4x_main_vtoolbar_changed"
list.cc(1228): warning #1011: missing return statement at end of
non-void function "d4x_main_vtoolbar_up"
list.cc(1236): warning #1011: missing return statement at end of
non-void function "d4x_main_vtoolbar_down"
lod.cc(841): warning #1011: missing return statement at end of
non-void function "_real_select_by_wildcard_"
lod.cc(847): warning #1011: missing return statement at end of
non-void function "_real_unselect_by_wildcard_"
lod.cc(1607): warning #1011: missing return statement at end of
non-void function "_foreach_invert_selection_"

It looks like there are a few missing return statements.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Saou 2005-05-03 07:49:16 EDT
Thanks for the bug report.  At the moment, the Fedora developers don't have
time to work on this particular issue. The best way to make sure your problem
will get looked on is to report it to the authors of the program. Most 
upstream authors use a bug tracking system like bugzilla, and more people
who know the code will be looking at the bug report there.

The upstream bug tracking system to use is:
http://www.krasu.ru/soft/chuchelo/forum.php3

Please make sure the bug isn't already in the upstream bug tracker before
filing it.

Note You need to log in before you can comment on or make changes to this bug.