Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1495489 - Failed to set nova service status to disabled
Summary: Failed to set nova service status to disabled
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Angus Thomas
QA Contact: Amit Ugol
URL:
Whiteboard:
: 1563646 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-26 07:44 UTC by Gurenko Alex
Modified: 2019-11-20 19:33 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-29 15:04:33 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gurenko Alex 2017-09-26 07:44:21 UTC
Description of problem:

Command "openstack compute service set compute-2 nova-compute --disable"
results in error and service remains active


Version-Release number of selected component (if applicable):

RHOS 10z5, build of 2017-09-20.2


How reproducible:


Steps to Reproduce:
1. Deploy RHOS 10 with 3 controllers and 3 computes
2. Execute source ~/overcloudrc && openstack compute service set compute-2 nova-compute --disable


Actual results:

Failed to set service status to disabled
Compute service nova-compute of host compute-2 failed to set.


Expected results:

Service disabled successfully


Additional info:

Comment 2 Gurenko Alex 2017-09-26 11:30:06 UTC
So, the problem is that only works with FQDN, e.g. compute-3.localdomain which is not exactly clear from https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/11/html/director_installation_and_usage/sect-scaling_the_overcloud#sect-Removing_Compute_Nodes in my opinion

Comment 3 Sylvain Bauza 2017-09-29 15:04:33 UTC
You're right, the canonical hostname used for disabling a service is the FQDN.
To make it clear, when you want to disable a specific compute service, you first need to get its canonical name by issuing 'openstack compute service list' and take the hostname accordingly.

Closing the bug, but feel free to reopen it if you consider something missing.

Comment 4 Ollie Walsh 2018-04-06 14:15:07 UTC
*** Bug 1563646 has been marked as a duplicate of this bug. ***

Comment 5 Kevin Carter 2019-11-20 19:30:21 UTC
While this particular issue is closed, for insight, an upstream review has been submitted to resolve this from within our automation: [ https://review.opendev.org/695288 ].


Note You need to log in before you can comment on or make changes to this bug.